<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7" lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7" lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8" lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9" lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html lang="en" dir="ltr"><!--<![endif]-->
<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
<meta charset="utf-8" />
<link rel="shortcut icon" href="https://enterprisersproject.com/sites/all/themes/oep/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="How are IT organizations using containers, what’s the best adoption pattern for you – and what speed bumps should you avoid?" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://enterprisersproject.com/article/2017/8/4-container-adoption-patterns-what-you-need-know" />
<link rel="shortlink" href="https://enterprisersproject.com/node/6496" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://enterprisersproject.com/article/2017/8/4-container-adoption-patterns-what-you-need-know" />
<meta property="og:title" content="4 container adoption patterns: What you need to know" />
<meta property="og:description" content="How are IT organizations using containers, what’s the best adoption pattern for you – and what speed bumps should you avoid?" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="4 container adoption patterns: What you need to know" />
<meta name="twitter:description" content="How are IT organizations using containers, what’s the best adoption pattern for you – and what speed bumps should you avoid?" />
<meta name="twitter:image" content="https://enterprisersproject.com/sites/default/files/images/CIO%20Containers%20Ecosystem.png" />
<title>4 container adoption patterns: What you need to know | The Enterprisers Project</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_Rdur8XVJnPlTNehlWLFbY-WXVG0stXacIOxyox8i_wE.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_GQN6nVuG_-TnCrtL4ScpBlsNpQ-W5NXw1-zzITx_WJA.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_uRd0VT6KL_vYlSNs4ibC9M_elNRoN5TS-y13lzKTZlo.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_JBdsfHcl2kad2WO-sMKq1mHdtJqRKONifqFm3y1esj8.css" media="screen" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?ougnzv" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?ougnzv" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?ougnzv" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?ougnzv" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_f8gWuoEJiafTr7WjJVGR2AOBaK0RPR53_yciBUapKME.css" media="only screen" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_wigS70piKQxAQ-PhuV0Kv5yYuTDEoD4yq0VyEj5L7HY.css" media="all" />

<!--[if (lt IE 9)&(!IEMobile 7)]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_QqmufzDHao3hMGSzkKy2pUNnwQSoS_EUGRmyJCMT2ZY.css" media="screen" />
<![endif]-->
<script src="https://enterprisersproject.com/sites/default/files/js/js_hbCs-Jp4M77A5aKC8_pY18-frLS-3JEeApksrZsRZlU.js"></script>
<script src="https://enterprisersproject.com/sites/default/files/js/js_Zl6_xGn1JzsPFVrsEs8ycLRbURvjZrRTrt8x23ZiKxM.js"></script>
<script src="https://enterprisersproject.com/sites/default/files/js/js_ciwdniwF82hviZ8GTKb5iMIu0zSHE5ou2b2KEdHW1QY.js"></script>
<script src="https://enterprisersproject.com/sites/default/files/js/js_ZXNbDTvbVRvH7INe4LLYZxrhSeWhy_W-lZ6JSqNnezk.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-44371138-1", {"cookieDomain":"auto"});ga("send", "pageview");</script>
<script src="//static.addtoany.com/menu/page.js"></script>
<script src="https://enterprisersproject.com/sites/default/files/js/js_DnuFZqAbXGXdNT6lDT3CZbc9RxAhigZkxpJjLt3TBjY.js"></script>
<script src="https://enterprisersproject.com/sites/default/files/js/js_Z1rMAOA2jn0APuP1PvZL7B4K9TRuzGwVIfSit8PNrRs.js"></script>
<script>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</script>
<!--[if lt IE 9]>
<script src="https://enterprisersproject.com/sites/all/themes/adaptivetheme/at_core/scripts/html5.js?ougnzv"></script>
<![endif]-->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-6496 node-type-article region-content site-name-hidden">
	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P2XC4"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-5P2XC4');</script>
	<!-- End Google Tag Manager -->
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<div class="region region-top-bar"><div class="region-inner clearfix"><div id="block-block-3" class="block block-block no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div id="mobnav-btn"><i class="icon-reorder"></i></div>
</div>
  </div></div><nav id="block-system-user-menu" class="block block-system block-menu no-title"  role="navigation"><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-8326"><a href="https://www.facebook.com/enterprisersproject" class="oep-facebook-menu" title="facebook">facebook</a></li><li class="leaf menu-depth-1 menu-item-1381"><a href="https://twitter.com/4enterprisers" class="oep-twitter-menu" title="twitter">Twitter</a></li><li class="leaf menu-depth-1 menu-item-1380"><a href="/rss" class="oep-rss-menu" title="rss">RSS</a></li><li class="leaf menu-depth-1 menu-item-649"><a href="/user/login">Log in</a></li><li class="last leaf menu-depth-1 menu-item-1301"><a href="/user/register" title="">Register</a></li></ul></div>
  </div></nav><div id="block-bean-sponsored-by-responsive" class="block block-bean no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="http://www.redhat.com/en?sc_cid=701600000011jKuAAI" target="_blank"><img src="https://enterprisersproject.com/sites/all/themes/oep/images/rh-sponsored-horizontal.svg" alt="Sponsored by RedHat" class="sponsored-by-responsive--image" /></a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div></div></div><div class="region region-mobile-nav"><div class="region-inner clearfix"><div id="block-block-5" class="block block-block no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-4 sf-parent-items-4 sf-single-items-0 primary-menu clearfix"><li id="menu-1116-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="https://enterprisersproject.com/" class="sf-depth-1 menuparent">Articles</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-8346-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/digital-transformation" class="sf-depth-2">Digital Transformation</a></li>
<li id="menu-8331-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/enterprise-technology" class="sf-depth-2">Enterprise Technology</a></li>
<li id="menu-8351-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/it-strategy" class="sf-depth-2">IT Strategy</a></li>
<li id="menu-8341-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/it-talent" class="sf-depth-2">IT Talent</a></li>
</ul></li>
<li id="menu-1181-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="https://enterprisersproject.com/cio-research" class="sf-depth-1 menuparent">CIO Research</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-8371-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/hbr-articles" class="sf-depth-2">HBR Articles</a></li>
<li id="menu-8356-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/researchreports" class="sf-depth-2">Research/Reports</a></li>
<li id="menu-8361-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/resources" class="sf-depth-2">Resources</a></li>
<li id="menu-8366-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/roundtables" class="sf-depth-2">Roundtables</a></li>
<li id="menu-5046-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/what-is-digital-transformation" class="sf-depth-2 sf-depth-2">What is Digital Transformation?</a></li>
</ul></li>
<li id="menu-1115-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="https://enterprisersproject.com/what-enterpriser" class="sf-depth-1 menuparent sf-depth-1 menuparent">What is an Enterpriser?</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-1119-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/meet-enterprisers" class="sf-depth-2 sf-depth-2">Meet the Enterprisers</a></li>
<li id="menu-1118-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/are-you-enterpriser" class="sf-depth-2 sf-depth-2">Are you an enterpriser?</a></li>
</ul></li>
<li id="menu-1117-1" class="last even sf-item-4 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="https://enterprisersproject.com/about-this-project" class="sf-depth-1 menuparent sf-depth-1 menuparent">About This Project</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-5031-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/how-contribute" class="sf-depth-2 sf-depth-2">How to Contribute</a></li>
<li id="menu-5016-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/faq-contributors" class="sf-depth-2 sf-depth-2">FAQs for Contributors</a></li>
</ul></li>
</ul></div>
  </div></div></div></div><div id="page" class="container page">

  <!-- region: Leaderboard -->
  
  <header id="header" class="clearfix" role="banner">

          <!-- start: Branding -->
      <div id="branding" class="branding-elements clearfix">

                  <div id="logo">
            <a href="/" title="Home page"><img class="site-logo image-style-none" src="https://enterprisersproject.com/sites/all/themes/oep/logo.png" alt="The Enterprisers Project" /></a>          </div>
        
                  <!-- start: Site name and Slogan hgroup -->
          <hgroup id="name-and-slogan">

                          <h1 class="element-invisible" id="site-name"><a href="/" title="Home page">The Enterprisers Project</a></h1>
            
                          <h2 id="site-slogan">A community of CIOs discussing the future of business and IT</h2>
            
          </hgroup><!-- /end #name-and-slogan -->
        
      </div><!-- /end #branding -->
    
    <!-- region: Header -->
    <div class="region region-header"><div class="region-inner clearfix"><div id="block-search-form" class="block block-search no-title"  role="search"><div class="block-inner clearfix">  
  
  <div class="block-content content"><form action="/article/2017/8/4-container-adoption-patterns-what-you-need-know" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="search" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-JQjrvHFyA_6JcKQr4uVRaPaBUI5XsgqdN89mSAailrw" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form></div>
  </div></div><div id="block-bean-sponsored-by" class="block block-bean no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p style="float: right;"><a href="http://www.redhat.com/en?sc_cid=701600000011jKuAAI" target="_blank"><img alt="Supported by Red Hat" src="https://enterprisersproject.com/sites/default/files/images/red_hat_supported_by_red.jpg" title="Supported by Red Hat" width="125" height="56" /></a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div></div></div>
  </header>

  <!-- Navigation elements -->
  <div id="menu-bar" class="nav clearfix"><nav id="block-superfish-1" class="block block-superfish no-title menu-wrapper menu-bar-wrapper clearfix" >  
  
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-4 sf-parent-items-4 sf-single-items-0 primary-menu clearfix"><li id="menu-1116-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/" class="sf-depth-1 menuparent">Articles</a> <div class="mobnav-subarrow"></div><ul><li id="menu-8346-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/digital-transformation" class="sf-depth-2">Digital Transformation</a></li><li id="menu-8331-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/enterprise-technology" class="sf-depth-2">Enterprise Technology</a></li><li id="menu-8351-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/it-strategy" class="sf-depth-2">IT Strategy</a></li><li id="menu-8341-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/it-talent" class="sf-depth-2">IT Talent</a></li></ul></li><li id="menu-1181-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/cio-research" class="sf-depth-1 menuparent">CIO Research</a> <div class="mobnav-subarrow"></div><ul><li id="menu-8371-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/cio-research/hbr-articles" class="sf-depth-2">HBR Articles</a></li><li id="menu-8356-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/cio-research/researchreports" class="sf-depth-2">Research/Reports</a></li><li id="menu-8361-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/cio-research/resources" class="sf-depth-2">Resources</a></li><li id="menu-8366-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/cio-research/roundtables" class="sf-depth-2">Roundtables</a></li><li id="menu-5046-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="/what-is-digital-transformation" class="sf-depth-2">What is Digital Transformation?</a></li></ul></li><li id="menu-1115-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/what-enterpriser" class="sf-depth-1 menuparent">What is an Enterpriser?</a> <div class="mobnav-subarrow"></div><ul><li id="menu-1119-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/meet-enterprisers" class="sf-depth-2">Meet the Enterprisers</a></li><li id="menu-1118-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/are-you-enterpriser" class="sf-depth-2">Are you an enterpriser?</a></li></ul></li><li id="menu-1117-1" class="last even sf-item-4 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/about-this-project" class="sf-depth-1 menuparent">About This Project</a> <div class="mobnav-subarrow"></div><ul><li id="menu-5031-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/how-contribute" class="sf-depth-2">How to Contribute</a></li><li id="menu-5016-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/faq-contributors" class="sf-depth-2">FAQs for Contributors</a></li></ul></li></ul>
  </nav></div>    
  <!-- Breadcrumbs -->
  <div id="breadcrumb" class="clearfix"><nav class="breadcrumb-wrapper clearfix" role="navigation"><h2 class="element-invisible">You are here</h2><ol id="crumbs" class="clearfix"><li class="crumb crumb-first"><a href="/">Home</a></li><li class="crumb"><span class="crumb-sepreator"> // </span><a href="/node/11">Articles</a></li><li class="crumb crumb-last"><span class="crumb-sepreator"> &#47; </span><span >4 container adoption patterns: What you need to know</span></li></ol></nav></div>
  <!-- Messages and Help -->
    
  <!-- region: Secondary Content -->
  
  <div id="columns" class="columns clearfix">
    <div id="content-column" class="content-column" role="main">
      <div class="content-inner">

        <!-- region: Highlighted -->
        
        <section id="main-content">

          
                      <header id="main-content-header" class="clearfix">

                              <h1 id="page-title">
                  4 container adoption patterns: What you need to know                </h1>
              
              
            </header>
          
          <!-- region: Main Content -->
                      <div id="content" class="region">
              <div id="block-system-main" class="block block-system no-title" >  
  
  
<div class="panel-display selby-flipped clearfix " >
  
  <div class="selby-flipped-content-container selby-flipped-container">
    <div class="selby-flipped-content-container-inner selby-flipped-container-inner">
    
      <div class="selby-flipped-column-content-region selby-flipped-content-header clearfix panel-panel">
        <div class="selby-flipped-column-content-region-inner selby-flipped-content-header-inner panel-panel-inner">
          <div class="panel-pane pane-node-title no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <h1>4 container adoption patterns: What you need to know</h1>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-article-subhead no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden view-mode-_custom_display">
    <div class="field-items">
                  <h2>How is IT using containers, what’s the best adoption pattern for you – and where are the speed bumps?</h2>
            </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-rate-widget no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-c20c77becfeb121e625fc144fd1533eb rate-node-6496-1-1" id="rate-node-6496-1-1"><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/2017/8/4-container-adoption-patterns-what-you-need-know?rate=F9tMl7nT-u-ai4nDpMu6krzfAQb4NcfAB6V-34EpBmg" title="up">up</a><div class="rate-info">6 readers like this</div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-node-author block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">By </h2>
        
    
    <div class="block-content">
      <a href="/user/ashesh-badani" title="View user profile." class="username">Ashesh Badani</a>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><section class="panel-pane pane-node-created block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title"> on </h2>
        
    
    <div class="block-content">
      August 14, 2017    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-basic-image-image no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-field-basic-image-image field-type-image field-label-hidden view-mode-_custom_display"><div class="field-items"><figure class="clearfix field-item even"><img class="620x350 image-style-620x350" src="https://enterprisersproject.com/sites/default/files/styles/620x350/public/images/CIO%20Containers%20Ecosystem.png?itok=lDTaYXzk" width="620" height="350" alt="CIO Containers Ecosystem" title="CIO Containers Ecosystem" /></figure></div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-body no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden view-mode-_custom_display"><div class="field-items"><div class="field-item even"><p>Containers have quickly won a key role in enterprise IT plans for a practical reason: They help organizations gain speed. And for digital businesses, speed equals revenue. But how are your peers using containers, what’s the best adoption pattern for your company – and what speed bumps should you avoid?</p>
<p>At this time of digital transformation, it’s crystal clear why today’s businesses desire speed. When a rival uses technology to make an unexpected move, or makes a big acquisition, you must react quickly. For example, the recent Amazon acquisition of Whole Foods demands fast action from supermarket competitors. To achieve that kind of business speed, IT leaders want to flip the 80/20 paradigm, where IT traditionally spent 80 percent of its budget on maintenance and 20 percent on innovation. CIOs seek to allocate more budget to help the business be agile and nimble. </p>
<p><strong>[ Want more background on using containers to aid agile dev teams? See our related article, <a href="https://enterprisersproject.com/article/2017/6/devops-success-new-team-model-emerges?sc_cid=70160000000h0aXAAQ" target="_blank">DevOps success: A new team model emerges</a>. ]</strong></p>
<p>Containers, DevOps, and microservices all fit together to help CIOs achieve that goal of agility. In short, containers corral applications in a neat package, isolated from the host system on which they run. Developers can easily move them around during experimentation, which is a fundamental part of DevOps. Containers also prove helpful as you move quickly from development to production environments. (For more, see this <a href="https://opensource.com/resources/what-are-linux-containers">background guide on containers.</a>)  Of course, technology alone doesn’t solve the problem. CIOs must also manage the cultural challenges that arise when you start working in cross-functional DevOps groups and rethinking boundaries and process. </p>
<p>But CIOs can learn plenty from their peers’ work on both fronts of culture and technology. On the technology side, when working in the trenches with companies adopting containers, you see many of the same goals and hurdles. Let’s examine the four typical ways companies adopt containers – and what you should know about each pattern.</p>
<h2><b>How companies tap into containers</b></h2>
<p>First, understand that there’s not one perfect container adoption path for your company. You may begin using containers on one path, then hop across to another later. Also, different groups inside a company often use containers in different ways - so it’s common to see multiple usage patterns at once. </p>
<h2><b>Pattern 1. Container Platform </b> </h2>
<p>Many companies begin using containers and then realize they need a platform. Often, a particular group, say a DevOps group, is working hard to drive change. This group needs an agile technology platform in order to experiment and deploy quickly, so they start working with containers. They get IT leadership on board, convincing them that containers are here to stay. The key question becomes, what platform will we use to deploy and manage the containers? While there are plenty of open source container tools to experiment with, an enterprise-grade container platform typically comprises dozens of open source projects, including Kubernetes orchestration, security, networking, management, build automation and continuous integration and deployment capabilities out of the box. In sum, a platform addresses management, governance, and security concerns.</p>
<p><b>Watch out for:</b></p>
<ul><li><b>Identify low hanging fruit</b>. Web servers and app servers are often easiest to deploy as containerized workloads to get a quick win. Then you can move on to databases and stateful systems. Pay close attention to integration with existing build and deployment tools and processes to demonstrate progress against status quo.</li>
<li><b>Prioritize container security</b>. Because containers contain system specific libraries and dependencies, they’re more prone to be affected by newly discovered security vulnerabilities.  Trusted registries, image scanning, and management tools can help identify and patch container images automatically. (For more background, see this Red Hat whitepaper: “<a href="https://www.redhat.com/en/resources/container-security-openshift-cloud-devops-whitepaper?sc_cid=701f2000000h46tAAA">10 layers of container security</a>.”)</li>
</ul><h2><b>Pattern 2. Cloud-native apps</b></h2>
<p>Some companies seek containers mostly to house cloud-native apps being created by application development teams, including new work and revamps of existing apps. These apps are often microservices-based. The goal is to break up an app into its underlying services, so teams can update the apps independently. Flexible APIs also typically fit in here. You want apps that can engage with other apps, systems, and data - both yours and your customers’ and partners’ – using a secure, well-understood set of APIs. You also need to integrate with existing systems. </p>
<p>Containers, in concert with microservices and APIs, make it easier for the dev teams to develop, collaborate, and deploy cloud-native apps.</p>
<p><b>Watch out for:</b></p>
<ul><li><b>Consider new runtimes</b> -- Monolithic app servers that you’ve deployed in the past will not likely run your next-gen apps in the future, as event-driven, reactive, and serverless technologies emerge. A container platform needs to supports a broad range of existing and cloud-native runtimes and frameworks.</li>
<li><b>Don’t forget about developer tools</b> -- While runtimes are evolving, new cloud-based developer tools promise  to eliminate the complexity of creating and managing different work environments, using self-learning technologies and automated workflows, to help developers build higher-quality code faster.</li>
</ul><h2><b>Pattern 3. Hybrid cloud</b></h2>
<p>In this commonly used pattern, an operations team, or another group managing a large group of apps, has seen the advantages of public cloud. Elasticity, speed, and performance have strong appeal. But the group needs to run some apps in existing on-premises environments - perhaps for historical, regulatory, or security reasons. The group also typically grapples with existing bare metal server or virtualized environments, and perhaps some existing private clouds. They may want more flexible storage options as well. For an IT group thinking about all this, cloud management becomes crucial. </p>
<p>The key questions: How do I get an abstraction level, a platform that runs well in all these environments and lets the operations team manage apps seamlessly? And how do I let developers deploy to one place, which can hide a variety of underlying infrastructures? That convenience is important to speed. </p>
<p><b>Watch out for:</b></p>
<ul><li><b>Culture change backlash</b>. As a banking CIO leading a significant transformation recently noted to me, none of this works unless people get on board with changes in mindset and behavior. IT leaders driving cultural change need support from both the C-suite and evangelists in the smaller teams.</li>
<li><b>Inertia.</b> The easiest thing to do is just do nothing. Some IT leaders will say “There’s so much change happening around me, I’ll just wait.” While you may be apprehensive to start the journey, or take a new hybrid cloud route, the business demand for speed will not go away.</li>
</ul><h2><b>Pattern 4. Business innovation</b></h2>
<p>In this pattern, a company starts up a small team to solve a specific business problem - say a mobile app to improve customer experience. The feeling is, “the way we’ve been working we’re not working quickly enough.” We need more modern practices. We need people to be change agents.” The company needs the group to quickly create, iterate, and make sure that IT can later scale out the solution. These groups often get new, enabling technologies and permission to run by different rules.</p>
<p><b>Watch out for:</b></p>
<ul><li><b>Debate around skills. </b>Expect to hear questions such as,<b> “</b>Do our IT team members have the skills to keep up with the group’s new technologies? Do we need a bunch of new hires? What about our investments in existing skills?” You will likely need a mix of both new hires and cross-training. Consider bringing an outside expert to assess the situation and put together a plan to get you where you want to be. (For more advice on team skills, see this related article: <a href="https://enterprisersproject.com/article/2017/7/ellucian-cio-cloud-era-demands-new-it-skillset"><b>Ellucian CIO: Cloud era demands new IT skillset</b></a>.)</li>
<li><b>Allow people to experiment and fail fast - or watch talent go elsewhere</b>. When companies don’t let IT teams experiment and fail fast, they struggle to attract talent. For example, take Macquarie Bank, based in Australia. Their CIO needs to recruit talent to build attention-grabbing customer experiences. One tactic: Within the first week of working at Macquarie, every new developer gets to push one change live. The recruiting message of the Facebooks of the world is “Come work on a feature used by millions.” The Macquarie CIO attracts people with the promise of experimentation and speed. (For more, see this <a href="https://www.redhat.com/en/resources/macquarie-bank-case-study">case study</a> on Red Hat’s work with Macquarie Bank.)</li>
</ul><h2><b>Parting advice </b></h2>
<p>No two digital transformations look alike. No two DevOps journeys will be the same. And as these four container adoption patterns show, you don’t have to use containers exactly like the company down the street, or like your rival. But you can learn from them. Consider these parting tips for IT leaders trying to move faster, using containers: </p>
<ul><li><b>Established companies will face greater challenges than cloud natives</b>. Netflix has pioneered with fast-moving dev teams, but Netflix had no existing infrastructure to throw out. Some CIOs still have COBOL apps to support. Grappling with both old and new technologies, and making tradeoffs, is normal. Make sure the C-suite understands that – and stop constantly comparing yourself to Netflix in this regard.</li>
<li><b>Don’t let scale concerns stop you in your tracks.</b> Only a few Facebooks exist in the world, scale-wise. You don’t need all the resources or skills of Facebook in order to make significant business change. Start experiments with smaller groups. As you succeed and become more comfortable, expand out in terms of technology and talent.</li>
<li><b>Coach people on the IT team to understand they’re not alone</b>. Encourage people on your team to engage with their peers outside the company, to talk about technology and culture challenges.</li>
</ul><p>Do you have additional advice for IT leaders pursuing speed using containers and/or DevOps? We’d love to hear from you in the comments section of this article.</p>
</div></div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-views-panes pane-related-articles-panel-pane-1 block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Related content</h2>
        
    
    <div class="block-content">
      <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 view-dom-id-97eb229c1eba278ad8aa70cb7b75e04a">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/how-do-cios-deal-agile-and-devops"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/Aaron%20Stibel%20CIO.jpg?itok=lfjzbGv7" width="222" height="125" alt="Aaron Stibel CIO" title="Aaron Stibel CIO" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/how-do-cios-deal-agile-and-devops">How do CIOs deal with agile and DevOps?</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/cio-innovation-wifi-superbowl"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/You%20May%20not%20Need%20Big%20Data%20Afterall_620x414.jpg?itok=g_ygVO6G" width="222" height="125" alt="Wifi at the Superbowl CIO" title="Wifi at the Superbowl CIO" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/cio-innovation-wifi-superbowl">CIO Innovation: WiFi at the SuperBowl</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd views-row-last">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/vanguard-cio-it-must-enable-and-accelerate-new-products-and-services"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/cio_reinvention_imperative.png?itok=ZnNKjTWV" width="222" height="125" alt="reinvention imperative" title="reinvention imperative" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/vanguard-cio-it-must-enable-and-accelerate-new-products-and-services">Vanguard CIO: IT must enable and accelerate new products and services</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-article-tags no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <section class="field field-name-field-article-tags field-type-taxonomy-term-reference field-label-inline clearfix view-mode-_custom_display"><h2 class="field-label">Tags:&nbsp;</h2><ul class="field-items"><li class="field-item even"><a href="/tags/containers">Containers</a></li><li class="field-item odd"><a href="/tags/enterprise-technology">Enterprise Technology</a></li></ul></section>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-post-comment pane-bean-post-comment-block-on-articles no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="button"><a href="#comment">Post Comment</a></div><span class='com_count'>Comments 0</span> | <span class='com_link'><a href='#comment'>Add yours Below</a></span>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-node-comment-form block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Comment Now</h2>
        
    
    <div class="block-content">
      <a name="comment"></a><form class="comment-form user-info-from-cookie" action="/article/2017/8/4-container-adoption-patterns-what-you-need-know#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<div class="form-item form-type-textfield form-item-homepage">
  <label for="edit-homepage">Homepage </label>
 <input type="text" id="edit-homepage" name="homepage" value="" size="30" maxlength="255" class="form-text" />
</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input type="hidden" name="form_build_id" value="form-cmhrBlenhWWFQohUHuJLFyFDHmvPwSLknfuNU2YzfyM" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-notify">
 <input type="checkbox" id="edit-notify" name="notify" value="1" class="form-checkbox" />  <label class="option" for="edit-notify">Notify me when new comments are posted </label>

</div>
<div id="edit-notify-type" class="form-radios"><div class="form-item form-type-radio form-item-notify-type">
 <input type="radio" id="edit-notify-type-1" name="notify_type" value="1" checked="checked" class="form-radio" />  <label class="option" for="edit-notify-type-1">All comments </label>

</div>
<div class="form-item form-type-radio form-item-notify-type">
 <input type="radio" id="edit-notify-type-2" name="notify_type" value="2" class="form-radio" />  <label class="option" for="edit-notify-type-2">Replies to my comment </label>

</div>
</div><div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/terms-and-conditions">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="" />
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="description mollom-privacy">By submitting this form, you accept the <a href="https://www.mollom.com/web-service-privacy-policy" class="mollom-target" rel="nofollow">Mollom privacy policy</a>.</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>    </div>

    
    
  </div>
</section>
        </div>
      </div>
      
      <div class="selby-flipped-content-container-column-container clearfix">
        <div class="selby-flipped-content-container-column-container-inner">
          <div class="selby-flipped-column-content-region selby-flipped-content-column1 selby-flipped-column panel-panel">
            <div class="selby-flipped-column-content-region-inner selby-flipped-content-column1-inner selby-flipped-column-inner panel-panel-inner">
                          </div>
          </div>
          <div class="selby-flipped-column-content-region selby-flipped-content-column2 selby-flipped-column panel-panel">
            <div class="selby-flipped-column-content-region-inner selby-flipped-content-column2-inner selby-flipped-column-inner panel-panel-inner">
                          </div>
          </div>
        </div>
      </div><!-- /.selby-flipped-content-container-column-container -->
      
      <div class="selby-flipped-column-content-region selby-flipped-content-footer clearfix panel-panel">
        <div class="selby-flipped-column-content-region-inner selby-flipped-content-footer-inner panel-panel-inner">
                  </div>
      </div>
      
    </div>
  </div><!-- /.selby-flipped-content-container -->
  
  <div class="selby-flipped-sidebar selby-flipped-column-content-region selby-flipped-column selby-flipped-container panel-panel">
    <div class="selby-flipped-sidebar-inner selby-flipped-column-content-region-inner selby-flipped-column-inner selby-flipped-container-inner panel-panel-inner">
      <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1 no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-7f60926ea5c16b9802a5aad20296a654">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-user-picture">        <div class="field-content"><img class="150x150 image-style-150x150" src="https://enterprisersproject.com/sites/default/files/styles/150x150/public/bio_ashesh_badani.png?itok=kPJhA7sf" width="150" height="150" alt="" /></div>  </div>  
  <div class="views-field views-field-field-user-about">        <span class="field-content">Ashesh Badani is responsible for Red Hat’s OpenShift business unit, focused on the company’s container application platform offerings and strategy. Previously, he oversaw product line management and marketing for Red Hat’s JBoss Enterprise Middleware portfolio. Prior to joining Red Hat, Badani served as director of product management and product marketing of integration and application platform products at Sun Microsystems and has over 15 years of experience in the technology and finance industry in established and emerging companies.
</span>  </div>  
  <div class="views-field views-field-nothing">        <span class="field-content"><a href="/user/ashesh-badani">» More about me</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-bean-widget-hbr-report-it-talent-cris no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/IT-Talent-Report" target="_blank"><img alt="Harvard Business Review: IT Talent Crisis: Proven Advice from CIOs and HR Leaders" class="media-image img__fid__379346 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__Harvard Business Review: IT Talent Crisis: Proven Advice from CIOs and HR Leaders attr__field_file_image_title_text[und][0][value]__Harvard attr__field_folder[und]__196" height="200" src="https://enterprisersproject.com/sites/default/files/widget_it_talent_crisis_hbr_report.png" title="Harvard Business Review: IT Talent Crisis: Proven Advice from CIOs and HR Leaders" width="300" /></a></p>
</div></div></div>  </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-bean-cios-we-welcome-you-to-join-the no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/how-contribute" target="_blank"><img alt="CIOs: We welcome you to join the conversation" class="media-image img__fid__379366 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__CIOs: We welcome you to join the conversation attr__field_file_image_title_text[und][0][value]__CIOs: attr__field_folder[und]__196" height="200" src="https://enterprisersproject.com/sites/default/files/widget_cios_we_welcome_you_join_conversation.png" title="CIOs: We welcome you to join the conversation" width="300" /></a></p>
</div></div></div>  </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-views pane-article-view block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Related Topics</h2>
        
    
    <div class="block-content">
      <div class="view view-article-view view-id-article_view view-display-id-block_3 view-dom-id-8e02333b6d51d07c27d6d3e3fdb9d191">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2017/8/5-ted-talks-transformational-leadership-watch">5 TED Talks on transformational leadership to watch</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/minda-zetlin" title="View user profile." class="username">Minda Zetlin</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">August 14, 2017</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>Want to bring transformational leadership to your IT group? Get informed and inspired.</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2017/8/5-ted-talks-transformational-leadership-watch">Read Article</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2017/8/hybrid-cloud-10-notable-statistics">Hybrid Cloud: 10 notable statistics</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/kevin-casey" title="View user profile." class="username">Kevin Casey</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">August 11, 2017</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>Want significant statistics on the present and future of hybrid cloud? We have you covered.</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2017/8/hybrid-cloud-10-notable-statistics">Read Article</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2017/8/leading-it-through-merger-cio-lessons-learned">Leading IT through a merger: CIO lessons learned</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/crudder" title="View user profile." class="username">Carla Rudder</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">August 10, 2017</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p><iframe allowfullscreen="" frameborder="0" height="390" mozallowfullscreen="" src="https://player.vimeo.com/video/222191276?title=0&amp;byline=0&amp;portrait=0" webkitallowfullscreen="" width="640"></iframe></p></div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2017/8/leading-it-through-merger-cio-lessons-learned">Read Article</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><section class="panel-pane pane-block pane-open-utils-twitter-oep block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Recent Tweets</h2>
        
    
    <div class="block-content">
      <a class="twitter-timeline"  href="https://twitter.com/4enterprisers"  data-widget-id="377195496453840896">Tweets by @4enterprisers</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><span class="twitter-icon"></span> | Follow <a href="http://www.twitter.com/4Enterprisers">@4Enterprisers</a>    </div>

    
    
  </div>
</section>
    </div>
  </div>
  
</div><!-- /.selby-flipped -->

  </div>            </div>
          
          <!-- Feed icons (RSS, Atom icons etc -->
          
          
        </section><!-- /end #main-content -->

        <!-- region: Content Aside -->
        
      </div><!-- /end .content-inner -->
    </div><!-- /end #content-column -->

    <!-- regions: Sidebar first and Sidebar second -->
        
  </div><!-- /end #columns -->

  <!-- region: Tertiary Content -->
  
  <!-- region: Footer -->

</div>

<footer id="footer" class="clearfix" role="contentinfo">
  <div class="region region-footer"><div class="region-inner clearfix"><section id="block-bean-about-this-site" class="block block-bean" ><div class="block-inner clearfix">  
      <h2 class="block-title">About This Site</h2>
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p>The Enterprisers Project is an online publication and community focused on connecting CIOs and senior IT leaders with the "who, what, and how" of IT-driven business innovation.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. <a href="http://enterprisersproject.com" title="The Enterprisers Project">The Enterprisers Project</a> aspires to publish all content under a <a href="http://creativecommons.org/licenses/" title="Creative Commons license">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
<div>A note on advertising: The Enterprisers Project does not sell advertising on the site or in any of its newsletters.</div>
</div></div></div>  </div>
</div>
</div>
  </div></section><section id="block-bean-connect" class="block block-bean" ><div class="block-inner clearfix">  
      <h2 class="block-title">Connect</h2>
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p class="footer-twitter"><a href="https://twitter.com/4enterprisers" target="_blank">Follow us @4Enterprisers on Twitter</a></p>
<p class="footer-facebook"><a href="https://www.facebook.com/enterprisersproject" target="_blank">Like The Enterprisers Project on Facebook</a></p>
<p class="footer-youtube"><a href="http://www.youtube.com/user/enterprisersproject" target="_blank">Watch us at The Enterprisers Project</a></p>
<p class="footer-linkedin"><a href="https://www.linkedin.com/company/the-enterprisers-project">Connect with us on Linkedin</a></p>
<p class="footer-rss"><a href="http://www.enterprisersproject.com/rss">RSS Feed</a></p>
</div></div></div>  </div>
</div>
</div>
  </div></section><section id="block-block-11" class="block block-block" ><div class="block-inner clearfix">  
      <h2 class="block-title">Subscribe to our newsletter</h2>
  
  <div class="block-content content"><p>Subscribe to get the latest thoughts, strategies, and insights from enterprising peers.</p>
<iframe id="dyfo" height="50" src="https://enterprisersproject.com/eloqua-embedded-subscribe.html?offer_id=70160000000eIYXAA2" frameborder="0" scrolling="no"></iframe></div>
  </div></section><div id="block-block-4" class="block block-block no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-8326"><a href="https://www.facebook.com/enterprisersproject" class="oep-facebook-menu" title="facebook">facebook</a></li>
<li class="leaf menu-depth-1 menu-item-1381"><a href="https://twitter.com/4enterprisers" class="oep-twitter-menu" title="twitter">Twitter</a></li>
<li class="leaf menu-depth-1 menu-item-1380"><a href="https://enterprisersproject.com/rss" class="oep-rss-menu" title="rss">RSS</a></li>
<li class="leaf menu-depth-1 menu-item-649"><a href="https://enterprisersproject.com/user/login">Log in</a></li>
<li class="last leaf menu-depth-1 menu-item-1301"><a href="https://enterprisersproject.com/user/register" title="">Register</a></li>
</ul></div>
  </div></div><div id="block-bean-copyright" class="block block-bean no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p>Copyright ©2017 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>
</div>
  </div></div><div id="block-bean-legal" class="block block-bean no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/privacy">Privacy Statement</a> | <a href="https://enterprisersproject.com/terms-and-conditions">Terms of use</a> | <a href="https://enterprisersproject.com/contact">Contact</a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div><div id="block-block-6" class="block block-block no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><!-- Google Code for Remarketing tag --><!-- Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. For instructions on adding this tag and more information on the above requirements, read the setup guide: google.com/ads/remarketingsetup --><script type="text/javascript">
<!--//--><![CDATA[// ><!--

/* <![CDATA[ */
var google_conversion_id = 990030321;
var google_conversion_label = "rxV4CN_35QQQ8dOK2AM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]]]><![CDATA[> */

//--><!]]>
</script><script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
<!--//--><![CDATA[// ><!--


//--><!]]>
</script><p></p><noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" /></div>
<p></p></noscript>
</div>
  </div></div></div></div></footer>

<div class="region region-tep-social"><div class="region-inner clearfix"><div id="block-tep-social-tep-social-share" class="block block-tep-social no-title" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style">
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  </div></div>
  </div></div></div></div>  <script src="https://enterprisersproject.com/sites/default/files/js/js_AebZV_tr2_bocSItbX3ykAeKs4gTP-sabM-wudz2eZA.js"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script>var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "4 container adoption patterns: What you need to know https://enterprisersproject.com/article/2017/8/4-container-adoption-patterns-what-you-need-know via @4enterprisers"
};</script>
</body>
</html>
