<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7" lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7" lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8" lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9" lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html lang="en" dir="ltr"><!--<![endif]-->
<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<link rel="shortcut icon" href="https://enterprisersproject.com/sites/all/themes/oep/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="description" content="What’s the state of Kubernetes? At Kubecon, I saw a lot of progress – but also, the need to focus on making Kubernetes more accessible to beginners." />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://enterprisersproject.com/article/2019/11/kubernetes-reality-check-3-takeaways-kubecon" />
<link rel="shortlink" href="https://enterprisersproject.com/node/12486" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://enterprisersproject.com/article/2019/11/kubernetes-reality-check-3-takeaways-kubecon" />
<meta property="og:title" content="Kubernetes reality check: 3 takeaways from KubeCon" />
<meta property="og:description" content="What’s the state of Kubernetes? At Kubecon, I saw a lot of progress – but also, the need to focus on making Kubernetes more accessible to beginners." />
<meta property="og:image" content="https://enterprisersproject.com/sites/default/files/cio_kubernetes.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Kubernetes reality check: 3 takeaways from KubeCon" />
<meta name="twitter:description" content="What’s the state of Kubernetes? At Kubecon, I saw a lot of progress – but also, the need to focus on making Kubernetes more accessible to beginners." />
<meta name="twitter:image" content="https://enterprisersproject.com/sites/default/files/cio_kubernetes.png" />
<title>Kubernetes reality check: 3 takeaways from KubeCon | The Enterprisers Project</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_Ttl7pXHUqYOH_6xFRsLkMmGN5alx7fVh3Om487xxFDs.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_ED1WelyPEctSssOtKfqCRYsbJGoMnuo95qvzH4aJvdY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_wNOKjUaI33fmVLWFPb00BtUGNvYWKA-soj_FO4ylCd0.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_f8gWuoEJiafTr7WjJVGR2AOBaK0RPR53_yciBUapKME.css" media="only screen" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />

<!--[if lt IE 9]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_QqmufzDHao3hMGSzkKy2pUNnwQSoS_EUGRmyJCMT2ZY.css" media="screen" />
<![endif]-->
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_0RyHJ63yYLuaWsodCPCgSD8dcTIA0dqcDf8-7c2XdBw.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_N3QrMaH3FSTG7AHsx81_k6rR6fScgg3ExVyzV8y3fcQ.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_DtBSLCkIkOZ3yvYCAEVYhd-lxagupjgu4EK2V6JpQvQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-44371138-1", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_Dq9icPpMam2QaSDmZOjgu71Tn5cD2k7EmQ95xntLB7U.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_yNEusE5awgqHKJOWCV8YYZyye7EMUKwc4i4hKysT1mg.js"></script>
<script type="text/javascript">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</script>
<!--[if lt IE 9]>
<script src="https://enterprisersproject.com/sites/all/themes/adaptivetheme/at_core/scripts/html5.js?q1xcs2"></script>
<![endif]-->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-12486 node-type-article region-content site-name-hidden atr-7.x-3.x atv-7.x-3.1">
	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P2XC4"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-5P2XC4');</script>
	<!-- End Google Tag Manager -->
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div class="region region-top-bar"><div class="region-inner clearfix"><div id="block-block-3" class="block block-block no-title odd first block-count-1 block-region-top-bar block-3" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div id="mobnav-btn"><i class="icon-reorder"></i></div>
</div>
  </div></div><nav id="block-system-user-menu" class="block block-system block-menu no-title even block-count-2 block-region-top-bar block-user-menu"  role="navigation"><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-8326"><a href="https://www.facebook.com/enterprisersproject" class="oep-facebook-menu" title="facebook">facebook</a></li><li class="leaf menu-depth-1 menu-item-1381"><a href="https://twitter.com/4enterprisers" class="oep-twitter-menu" title="twitter">Twitter</a></li><li class="leaf menu-depth-1 menu-item-1380"><a href="/rss" class="oep-rss-menu" title="rss">RSS</a></li><li class="leaf menu-depth-1 menu-item-649"><a href="/user/login">Log in</a></li><li class="last leaf menu-depth-1 menu-item-1301"><a href="/user/register" title="">Register</a></li></ul></div>
  </div></nav><div id="block-bean-sponsored-by-responsive" class="block block-bean no-title odd last block-count-3 block-region-top-bar block-sponsored-by-responsive" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://www.redhat.com/en?intcmp=701600000011jKuAAI" target="_blank"><img src="https://enterprisersproject.com/sites/all/themes/oep/images/rh-sponsored-horizontal.svg" alt="Sponsored by RedHat" class="sponsored-by-responsive--image" /></a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div></div></div><div class="region region-mobile-nav"><div class="region-inner clearfix"><div id="block-block-5" class="block block-block no-title odd first last block-count-4 block-region-mobile-nav block-5" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-4 sf-parent-items-4 sf-single-items-0 primary-menu clearfix"><li id="menu-1116-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-4 sf-parent-children-1 sf-single-children-3 menuparent"><a href="https://enterprisersproject.com/" class="sf-depth-1 menuparent">Articles</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-8346-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/digital-transformation" class="sf-depth-2">Digital Transformation</a></li>
<li id="menu-8331-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="https://enterprisersproject.com/tags/enterprise-technology" class="sf-depth-2 menuparent">Enterprise Technology</a>
<ul><li id="menu-9086-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="https://enterprisersproject.com/tags/hybrid-cloud" class="sf-depth-3">Hybrid cloud</a></li>
</ul></li>
<li id="menu-8351-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/it-strategy" class="sf-depth-2">IT Strategy</a></li>
<li id="menu-8341-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/it-talent" class="sf-depth-2">IT Talent</a></li>
</ul></li>
<li id="menu-1181-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="https://enterprisersproject.com/cio-research" class="sf-depth-1 menuparent">CIO Research</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-8371-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/hbr-articles" class="sf-depth-2">HBR Articles</a></li>
<li id="menu-8356-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/researchreports" class="sf-depth-2">Research/Reports</a></li>
<li id="menu-8361-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/resources" class="sf-depth-2">Resources</a></li>
<li id="menu-8366-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/roundtables" class="sf-depth-2">Roundtables</a></li>
<li id="menu-5046-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/what-is-digital-transformation" class="sf-depth-2 sf-depth-2">What is Digital Transformation?</a></li>
<li id="menu-10231-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/it-automation" class="sf-depth-2 sf-depth-2">Automation: The IT leader's guide</a></li>
<li id="menu-9731-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/devops" class="sf-depth-2 sf-depth-2">DevOps: The IT Leader's Guide</a></li>
<li id="menu-9576-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/hybrid-cloud" class="sf-depth-2 sf-depth-2">Hybrid cloud: The IT leader's guide</a></li>
<li id="menu-11696-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/ultimate-devops-hiring-guide" class="sf-depth-2 sf-depth-2">The ultimate DevOps hiring guide</a></li>
</ul></li>
<li id="menu-1115-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="https://enterprisersproject.com/what-enterpriser" class="sf-depth-1 menuparent sf-depth-1 menuparent">What is an Enterpriser?</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-1119-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/meet-enterprisers" class="sf-depth-2 sf-depth-2">Meet the Enterprisers</a></li>
<li id="menu-1118-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/are-you-enterpriser" class="sf-depth-2 sf-depth-2">Are you an enterpriser?</a></li>
</ul></li>
<li id="menu-1117-1" class="last even sf-item-4 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="https://enterprisersproject.com/about-this-project" class="sf-depth-1 menuparent sf-depth-1 menuparent">About This Project</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-5031-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/how-contribute" class="sf-depth-2 sf-depth-2">How to Contribute</a></li>
<li id="menu-5016-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/faq-contributors" class="sf-depth-2 sf-depth-2">Contributor Guidelines</a></li>
</ul></li>
</ul></div>
  </div></div></div></div><div id="page" class="container page">

  <!-- region: Leaderboard -->
  
  <header id="header" class="clearfix" role="banner">

          <!-- start: Branding -->
      <div id="branding" class="branding-elements clearfix">

                  <div id="logo">
            <a href="/"><img class="site-logo" src="https://enterprisersproject.com/sites/all/themes/oep/logo.png" alt="The Enterprisers Project" /></a>          </div>
        
                  <!-- start: Site name and Slogan hgroup -->
          <hgroup class="h-group" id="name-and-slogan">

                          <h1 class="element-invisible" id="site-name"><a href="/" title="Home page">The Enterprisers Project</a></h1>
            
                          <h2 id="site-slogan">A community helping CIOs and IT leaders solve problems</h2>
            
          </hgroup><!-- /end #name-and-slogan -->
        
      </div><!-- /end #branding -->
    
    <!-- region: Header -->
    <div class="region region-header"><div class="region-inner clearfix"><div id="block-search-form" class="block block-search no-title odd first block-count-5 block-region-header block-form"  role="search"><div class="block-inner clearfix">  
  
  <div class="block-content content"><form action="/article/2019/11/kubernetes-reality-check-3-takeaways-kubecon" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="search" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-rMuMEh9cVL1SJe2_WAEV7SZPcD5KjyCVT_hltHswxo8" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form></div>
  </div></div><div id="block-bean-sponsored-by" class="block block-bean no-title even last block-count-6 block-region-header block-sponsored-by" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p style="float: right;"><a href="https://www.redhat.com/en?intcmp=701600000011jKuAAI" target="_blank"><img alt="Supported by Red Hat" src="https://enterprisersproject.com/sites/all/themes/oep/images/red_hat_supported_by_red.svg" title="Supported by Red Hat" width="125" height="56" /></a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div></div></div>
  </header>

  <!-- Navigation elements -->
  <div id="menu-bar" class="nav clearfix"><nav id="block-superfish-1" class="block block-superfish no-title menu-wrapper menu-bar-wrapper clearfix odd first last block-count-7 block-region-menu-bar block-1" >  
  
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-4 sf-parent-items-4 sf-single-items-0 primary-menu clearfix"><li id="menu-1116-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-4 sf-parent-children-1 sf-single-children-3 menuparent"><a href="/" class="sf-depth-1 menuparent">Articles</a> <div class="mobnav-subarrow"></div><ul><li id="menu-8346-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/digital-transformation" class="sf-depth-2">Digital Transformation</a></li><li id="menu-8331-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/enterprise-technology" class="sf-depth-2 menuparent">Enterprise Technology</a><ul><li id="menu-9086-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/hybrid-cloud" class="sf-depth-3">Hybrid cloud</a></li></ul></li><li id="menu-8351-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/it-strategy" class="sf-depth-2">IT Strategy</a></li><li id="menu-8341-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/it-talent" class="sf-depth-2">IT Talent</a></li></ul></li><li id="menu-1181-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/cio-research" class="sf-depth-1 menuparent">CIO Research</a> <div class="mobnav-subarrow"></div><ul><li id="menu-8371-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/cio-research/hbr-articles" class="sf-depth-2">HBR Articles</a></li><li id="menu-8356-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/cio-research/researchreports" class="sf-depth-2">Research/Reports</a></li><li id="menu-8361-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/cio-research/resources" class="sf-depth-2">Resources</a></li><li id="menu-8366-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/cio-research/roundtables" class="sf-depth-2">Roundtables</a></li><li id="menu-5046-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/what-is-digital-transformation" class="sf-depth-2">What is Digital Transformation?</a></li><li id="menu-10231-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/it-automation" class="sf-depth-2">Automation: The IT leader&#039;s guide</a></li><li id="menu-9731-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/devops" class="sf-depth-2">DevOps: The IT Leader&#039;s Guide</a></li><li id="menu-9576-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/hybrid-cloud" class="sf-depth-2">Hybrid cloud: The IT leader&#039;s guide</a></li><li id="menu-11696-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="/ultimate-devops-hiring-guide" class="sf-depth-2">The ultimate DevOps hiring guide</a></li></ul></li><li id="menu-1115-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/what-enterpriser" class="sf-depth-1 menuparent">What is an Enterpriser?</a> <div class="mobnav-subarrow"></div><ul><li id="menu-1119-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/meet-enterprisers" class="sf-depth-2">Meet the Enterprisers</a></li><li id="menu-1118-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/are-you-enterpriser" class="sf-depth-2">Are you an enterpriser?</a></li></ul></li><li id="menu-1117-1" class="last even sf-item-4 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/about-this-project" class="sf-depth-1 menuparent">About This Project</a> <div class="mobnav-subarrow"></div><ul><li id="menu-5031-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/how-contribute" class="sf-depth-2">How to Contribute</a></li><li id="menu-5016-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/faq-contributors" class="sf-depth-2">Contributor Guidelines</a></li></ul></li></ul>
  </nav></div>    
  <!-- Breadcrumbs -->
  
  <!-- Help -->
  
  <!-- region: Secondary Content -->
  
  <div id="columns" class="columns clearfix">
    <div id="content-column" class="content-column" role="main">
      <div class="content-inner">

        <!-- region: Highlighted -->
        
        <section id="main-content">

          
                      <header id="main-content-header" class="clearfix">

                              <h1 id="page-title">
                  Kubernetes reality check: 3 takeaways from KubeCon                </h1>
              
              
            </header>
          
          <!-- region: Main Content -->
                      <div id="content" class="region">
              <div id="block-system-main" class="block block-system no-title odd first last block-count-8 block-region-content block-main" >  
  
  
<div class="panel-display selby-flipped clearfix radix-selby-flipped" >

  <div class="container-fluid">
    <div class="row">
      <div class="col-md-8 panel-panel">
        <div class="row">
          <div class="col-md-12 radix-layouts-contentheader panel-panel">
            <div class="panel-pane pane-node-title no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <h1>Kubernetes reality check: 3 takeaways from KubeCon</h1>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-article-subhead no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden view-mode-_custom_display">
    <div class="field-items">
                  <h2>What&#039;s the state of Kubernetes? At Kubecon, I saw a lot of progress – but also, the need to focus on making Kubernetes more accessible to beginners</h2>
            </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-rate-widget no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-77eae2211857c3a7c1700ffaebe3d702 rate-node-12486-1-1" id="rate-node-12486-1-1"><a class="rate-button rate-thumbs-up-btn-up vote-pending" id="rate-button-2" rel="nofollow" href="/article/2019/11/kubernetes-reality-check-3-takeaways-kubecon?rate=6i34PyToOBmcgUTf6gsAP07dvNoZ-JM5pIiHN_w5OJE" title="up">up</a><div class="rate-info">12 readers like this</div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-views-panes pane-article-details-panel-pane-byline no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="view view-article-details view-id-article_details view-display-id-panel_pane_byline view-dom-id-14551d4ed132e1ec800cd85539a64019">
        
  
  
      <div class="view-content">
        <div>
      
          <div class="submited-by">By <a href="/user/gordon-haff" title="View user profile." class="username">Gordon Haff</a>  | November 25, 2019</div>    </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-basic-image-image no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-field-basic-image-image field-type-image field-label-hidden view-mode-_custom_display"><div class="field-items"><figure class="clearfix field-item even"><img class="620x350 image-style-620x350" src="https://enterprisersproject.com/sites/default/files/styles/620x350/public/cio_kubernetes.png?itok=wDep5_PX" width="620" height="350" alt="Kubernetes" title="Kubernetes" /></figure></div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-body no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden view-mode-_custom_display"><div class="field-items"><div class="field-item even"><p>Last week’s <a href="https://events19.linuxfoundation.org/events/kubecon-cloudnativecon-north-america-2019/">KubeCon and CloudNativeCon</a> conferences drew about 12,000 attendees to San Diego. That’s the most ever and speaks to how interest in <a href="https://www.redhat.com/en/topics/containers/what-is-kubernetes?intcmp=701f2000000tjyaAAA" target="_blank">Kubernetes</a>, the many projects that augment and work with it, and the products based on those upstream projects continues to increase.</p>
<p>But all this activity comes with a price.</p>
<h2>1. Kubernetes still feels complex to beginners</h2>
<p>Well over half the attendees were conference first-timers. On the one hand, lots of new blood is a sign of a healthy community. On the other hand… well, I’ll let one such first-timer, consultant and industry analyst Keith Townsend, <a href="https://twitter.com/CTOAdvisor/status/1196848481291255808?s=20">speak for himself</a>: “I’m not shy in saying I don’t know what’s going on at this keynote. It’s not aimed at me or people like me for sure. To use a metaphor - it feels like I’ve been dropped in the middle of an industry conference like the American Medical Association. There are some words and concepts I understand, but overall I’m lost. And there are very few IT topics,” he noted on Twitter.</p>
<p>Enterprise distributions can help to abstract away some of this complexity by making opinionated choices about components and otherwise packaging the <a href="https://www.redhat.com/en/topics/cloud-native-apps?intcmp=701f2000000tjyaAAA" target="_blank">cloud-native</a> ecosystem into a more consumable form.</p>
<p><strong>[ Want more detail here? Read also: <a href="https://www.redhat.com/en/blog/openshift-and-kubernetes-whats-difference?intcmp=701f2000000tjyaAAA">OpenShift and Kubernetes: What’s the difference?</a> ]</strong></p>
<p>That said, there’s a lot of rapid evolution and change going on in areas as diverse as <a href="https://www.redhat.com/en/topics/microservices/what-is-a-service-mesh?intcmp=701f2000000tjyaAAA" target="_blank">service mesh</a>, <a href="https://enterprisersproject.com/article/2018/9/what-serverless">serverless</a>, policy, monitoring, visualization, and more. Part of the reason is that container-centric cloud-native computing rethinks many traditional more server-centric computing models.</p>
<p></p><div class="embedded-callout-text callout-float-right">We’re seeing an ongoing replacement of the software that came from that server-centric world with new projects and approaches.</div>
<p>As a result, we’re seeing an ongoing replacement of the software that came from that server-centric world with new projects and approaches. With, of course, the expected missteps and trial-and-error learning along the way.</p>
<p>While all this is mostly a good thing for advancing the state of the art of computing infrastructure, the various communities involved need to think harder about gentler on-ramps for those people just getting up to speed.</p>
<p><b>[ Want a primer for yourself and others? Read also: </b><b><a href="https://enterprisersproject.com/article/2017/10/how-explain-kubernetes-plain-english?sc_cid=70160000000h0axaaq">How to explain Kubernetes in plain English</a> and <a href="https://enterprisersproject.com/article/2019/2/kubernetes-operators-plain-english?sc_cid=70160000000h0aXAAQ">How to explain Kubernetes Operators in plain English</a>.</b><b> ]</b></p>
<h2>2. It’s not (yet) about the apps</h2>
<p>Complexity aside, though, I’d argue that there’s a relatively complete vision here for how computing infrastructure should function as we enter the 2020’s. Details will change, of course, and over the coming years we’ll likely see major new concepts introduced. But the basic new infrastructure model is in place – if unevenly deployed in enterprises so far.</p>
<p></p><div class="embedded-callout-text callout-float-right">The basic new infrastructure model is in place: Less has happened on the application front.</div>
<p>Less has happened on the application front. We have concepts like microservices. We have some new languages, like <a href="https://golang.org">Go</a>, that were born within a cloud computing context. (Open source language Go was developed within <a href="https://www.google.com/">Google</a>.) However, from an application developer perspective, we’re arguably still writing a vast amount of code using tools that don’t directly embed the sort of emerging patterns we see in cloud-native.</p>
<p>There is progress on some fronts. For example, service meshes deal with the problem of secure communication among services by removing those duties from the hands of the app developer. However, in general, it seems as if there’s been far less activity aimed at helping developers write cloud-native apps better and faster – with less need for advanced programming skills – than has gone into creating infrastructure.</p>
<p>And this mindset shows at KubeCon as a whole. One can argue whether KubeCon is wholly an infrastructure conference. But it certainly isn’t an event that’s really aimed at application developers.</p>
<h2>3. Operating securely is an important user concern</h2>
<p>There were more <a href="https://enterprisersproject.com/tags/security">security </a>sessions and more security vendors present at this KubeCon than at any prior one. There’s a lot of interest in security out there, noted a cloud-native security panel made up of Liz Rice (VP open source engineering, <a href="https://www.aquasec.com">Aqua Security</a>), Michael Ducy (director of community and evangelism,<a href="https://sysdig.com"> Sysdig</a>), Sabree Blackmon (formerly a senior security engineer at <a href="https://www.docker.com">Docker</a>), Gareth Rushgrove (director of product management, <a href="https://snyk.io">Snyk</a>), and Maya Kaczorowski (product manager, Google security team). However, Rushgrove, who is also in the <a href="https://www.cncf.io/">Cloud Native Computing Foundation</a> (CNCF) <a href="https://github.com/cncf/sig-security">Security special interest group</a>, also said that a lot of the interest he sees in that group is in fairly basic topics, such as image scanning and general automation.</p>
<p>A great deal of work has gone into security around Kubernetes: I asked the panelists where work remained to be done. The group had no shortage of answers.</p>
<p></p><div class="embedded-callout-text callout-float-right">Plenty of Kubernetes security work remains to be done.</div>
<p>One area concerns defaults. Security in a project like Kubernetes, like many other projects, sometimes has default settings that may make the project easier to adopt or use but that aren’t best practice from a security perspective. (We’ve seen the same problem with containers more generally with the use of root access and other escalated permissions.) Kaczorowski said we need to consider making defaults more locked down.</p>
<p><strong>[ Read also: <a href="https://enterprisersproject.com/article/2019/5/kubernetes-security-4-tips">Kubernetes security: 4 strategic tips</a>. ]</strong></p>
<p>Another security theme concerned policy management. The <a href="https://www.openpolicyagent.org/">Open Policy Agent</a> (OPA) is one tool that aims to simplify security policy (like <a href="https://enarx.io">Enarx </a>for Trusted Execution Environments). As the <a href="http://www.openpolicyagent.org/">Open Policy Agent</a> (OPA) site states, OPA “has been used to policy-enable software across several different domains across several layers of the stack: container management (Kubernetes), servers (Linux), public cloud infrastructure (Terraform), and microservice APIs (Istio, Linkerd, CloudFoundry).”</p>
<p>OPA’s policy language, Rego, “manages to work for all these different domains and layers of the stack without requiring any changes or extensions to the language.”</p>
<p>Rego lets you write logic to search and combine JSON/YAML data from different sources to ask questions like “Is this API allowed?”</p>
<p>What does that mean for developers? “The key idea is that while you as an author are thinking about servers, containers, or APIs, Rego just sees JSON/YAML data,” notes the OPA site.</p>
<p>The panel noted that while the tools for policy management are falling into place, a lot of the actual policy isn’t written yet. More advanced network policies and policies across distributed clusters were also highlighted as areas where more work was needed.</p>
<p></p><div class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-default view-dom-id-54cbfca135d2a967270ef5b8b45dd872">
            <div class="view-header">
      <p>MORE ON KUBERNETES</p>
    </div>
  
  
  
      <div class="view-content">
          <ul><li class="">  
          <a href="https://enterprisersproject.com/article/2017/11/kubernetes-numbers-10-compelling-stats">Kubernetes by the numbers: 10 compelling stats</a>  </li>
          <li class="">  
          <a href="https://enterprisersproject.com/article/2018/11/kubernetes-production-4-myths-debunked">Kubernetes in production vs. Kubernetes in development: 4 myths</a>  </li>
          <li class="">  
          <a href="https://enterprisersproject.com/article/2019/4/6-kubernetes-security-questions-answered">6 Kubernetes security questions, answered</a>  </li>
      </ul></div>
  
  
  
  
  
  
</div></div>
<p>Finally, the panelists reiterated that people still get a lot of the security basics wrong. They don’t think about their software supply chains and they run images they download from untrusted sources. They run containers as root or otherwise use permissions that open them up to security problems. Many developers are quite new to security. And in general, “security people don’t understand Kubernetes.”</p>
<p>Which leads back to the defaults discussion and the panel’s general conclusion that products in this space need to be more opinionated, as a way of leading possibly unsophisticated users to adopt good security practices.</p>
<p><b>[ Kubernetes terminology, demystified: Get our </b><a href="https://enterprisersproject.com/kubernetes-glossary?sc_cid=70160000000h0axaaq"><b>Kubernetes glossary</b></a><b> cheat sheet for IT and business leaders. ]</b></p>
</div></div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-views pane-cta no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="view view-cta view-id-cta view-display-id-block view-dom-id-fbe2538b65169425b2d1e2d0f5874214">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
    
<div class="fieldable-panels-pane cta cta--red-on-white cta--no-link">
  <div class="cta__inner cta__inner--no-link">
    <div class="cta__content cta__content--no-link clearfix">
                  <div class="field field-name-field-cta-content field-type-text-long field-label-hidden view-mode-full"><div class="field-items"><div class="field-item even"><div class="cta__text-and-form">
<div class="cta__text">
<h2 class="cta__title">SUBSCRIBE TO OUR NEWSLETTER</h2>
<p>Stay on top of the latest thoughts, strategies and insights from enterprising peers.</p>
</div>
<div class="cta__form">
<iframe class="eloqua-embedded-bottom" frameborder="0" height="50" id="fkfkx" scrolling="no" src="https://enterprisersproject.com/eloqua-embedded-cta.html?offer_id=70160000000eIYXAA2" style="max-width:600px;margin:0 auto;" width="100%"></iframe></div>
</div>
</div></div></div>    </div>
  </div>
</div>


  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-views-panes pane-related-articles-panel-pane-1 block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Related content</h2>
        
    
    <div class="block-content">
      <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 view-dom-id-8b22ab6780ae7a1cca5b441fa0caed24">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/2019/12/digital-transformation-money-wasters"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/cio_digital_transformation_spending.png?itok=NzSsyGWX" width="222" height="125" alt="digital transformation spending" title="digital transformation spending" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2019/12/digital-transformation-money-wasters">Digital transformation: 10 sneaky money-wasters</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/2019/11/5-must-read-harvard-business-review-articles-december"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/Harvard%20Business%20Review%20Top%205.png?itok=EmpMOBTY" width="222" height="125" alt="Harvard Business Review Top 5 articles for October 2015" title="Harvard Business Review Top 5 articles for October 2015" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2019/11/5-must-read-harvard-business-review-articles-december">5 must-read Harvard Business Review articles in December</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd views-row-last">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/2019/11/digital-transformation-3-people-pain-points"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/cio_digital_transformation_advice.png?itok=hNAhQuLf" width="222" height="125" alt="digital transformation advice " title="digital transformation advice " /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2019/11/digital-transformation-3-people-pain-points">Digital transformation: 3 people pain points </a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-article-tags no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <section class="field field-name-field-article-tags field-type-taxonomy-term-reference field-label-inline clearfix view-mode-_custom_display"><h2 class="field-label">Tags:&nbsp;</h2><ul class="field-items"><li class="field-item even"><a href="/tags/it-strategy">IT Strategy</a></li><li class="field-item odd"><a href="/tags/containers">Containers</a></li><li class="field-item even"><a href="/tags/automation">Automation</a></li></ul></section>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-post-comment pane-bean-post-comment-block-on-articles no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <span class="post-comment-count">No comments yet</span>, <a class="post-comment-link" href="#comment">Add yours below</a>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-node-comment-form block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Comment Now</h2>
        
    
    <div class="block-content">
      <a name="comment"></a><form class="comment-form user-info-from-cookie" action="/article/2019/11/kubernetes-reality-check-3-takeaways-kubecon#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<div class="form-item form-type-textfield form-item-homepage">
  <label for="edit-homepage">Homepage </label>
 <input type="text" id="edit-homepage" name="homepage" value="" size="30" maxlength="255" class="form-text" />
</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input type="hidden" name="form_build_id" value="form-gDTmApgEf3-Ny3DJo3qp1LfNSkL58_FAX0KIlfbaYi0" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-notify">
 <input type="checkbox" id="edit-notify" name="notify" value="1" class="form-checkbox" />  <label class="option" for="edit-notify">Notify me when new comments are posted </label>

</div>
<div id="edit-notify-type" class="form-radios"><div class="form-item form-type-radio form-item-notify-type">
 <input type="radio" id="edit-notify-type-1" name="notify_type" value="1" checked="checked" class="form-radio" />  <label class="option" for="edit-notify-type-1">All comments </label>

</div>
<div class="form-item form-type-radio form-item-notify-type">
 <input type="radio" id="edit-notify-type-2" name="notify_type" value="2" class="form-radio" />  <label class="option" for="edit-notify-type-2">Replies to my comment </label>

</div>
</div><input type="hidden" name="honeypot_time" value="1575357291|LsS8vtKbuCCBBKTSgS01AfnsLmWDsaUfe0jxI_GzHGs" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/terms-and-conditions">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="captcha"><input type="hidden" name="captcha_sid" value="51891686" />
<input type="hidden" name="captcha_token" value="67e77fe5bb583cb0094a8af501f30b9d" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdzKzYUAAAAAMFHjKIs8QmN8y2QGTgbO6ze0Rgn" data-theme="light" data-type="image"></div></div><div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Submit Comment" class="form-submit" /></div></div></form>    </div>

    
    
  </div>
</section>
          </div>
        </div>
        <div class="row">
          <div class="col-md-6 radix-layouts-contentcolumn1 panel-panel">
                      </div>
          <div class="col-md-6 radix-layouts-contentcolumn2 panel-panel">
                      </div>
        </div>
        <div class="row">
          <div class="col-md-12 radix-layouts-contentfooter panel-panel">
                      </div>
        </div>
      </div>
      <div class="col-md-4 radix-layouts-sidebar panel-panel">
        <div class="panel-panel-inner">
          <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1 no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-818ec7c15630c4666a862b82496afaf8">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-user-picture">        <div class="field-content"><img class="150x150 image-style-150x150" src="https://enterprisersproject.com/sites/default/files/styles/150x150/public/bio_gordon_haff.png?itok=oDLek2z_" width="150" height="150" alt="" /></div>  </div>  
  <div class="views-field views-field-field-user-about">        <span class="field-content">Gordon Haff is Technology Evangelist at Red Hat where he works on product strategy, writes about trends and technologies, and is a frequent speaker at customer and industry events on topics including DevOps, IoT, cloud computing, containers, and next-generation application architectures.</span>  </div>  
  <div class="views-field views-field-nothing">        <span class="field-content"><a href="/user/gordon-haff">» More about me</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-bean-hbr-ai-report-widget no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p></p><div class="media media-element-container media-default"><div id="file-392821" class="file file-image file-image-png">

        <h2 class="element-invisible"><a href="https://enterprisersproject.com/files/hbraireportwidgetpng">hbr_ai_report_widget.png</a></h2>
    
  
  <div class="content">
          <a href="https://enterprisersproject.com/ai-executives-guide?sc_cid=701f20000012jUeAAI"><img class="media-element file-default panopoly-image-original image-style-panopoly-image-original" data-delta="1" src="https://enterprisersproject.com/sites/default/files/styles/panopoly_image_original/public/images/hbr_ai_report_widget.png?itok=9KBL0Wpf" alt="" /></a>
        </div>

  
</div>
</div>
<p> </p>
</div></div></div>  </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-block-36 no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <p><a href="https://enterprisersproject.com/cio-new-rules-infographic?intcmp=701f2000000rcquaak"><img alt="7 New CIO Rules of Road " src="https://enterprisersproject.com/sites/default/files/styles/panopoly_image_original/public/images/new_rules_infographic_widget3.png" title="7 New CIO Rules of Road " width="300" height="200" /></a></p>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-bean-cios-we-welcome-you-to-join-the no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/how-contribute" target="_blank"><img alt="CIOs: We welcome you to join the conversation" class="media-image img__fid__379366 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__CIOs: We welcome you to join the conversation attr__field_file_image_title_text[und][0][value]__CIOs: attr__field_folder[und]__196" height="200" src="https://enterprisersproject.com/sites/default/files/widget_cios_we_welcome_you_join_conversation.png" title="CIOs: We welcome you to join the conversation" width="300" /></a></p>
</div></div></div>  </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-views pane-article-view block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Related Topics</h2>
        
    
    <div class="block-content">
      <div class="view view-article-view view-id-article_view view-display-id-block_3 view-dom-id-636845700d3f5bfcaeb62c4d11074692">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2019/12/digital-transformation-money-wasters">Digital transformation: 10 sneaky money-wasters</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/stephanie-overby" title="View user profile." class="username">Stephanie Overby</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">December 02, 2019</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>Digital transformation work remains at the top of IT leaders’ to-do lists. But there’s only so much funding. Are you falling into any of these spending traps?</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2019/12/digital-transformation-money-wasters">Read Article</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2019/11/5-must-read-harvard-business-review-articles-december">5 must-read Harvard Business Review articles in December</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/crudder" title="View user profile." class="username">Carla Rudder</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">December 02, 2019</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>Check out these five thought-provoking HBR articles, curated especially for CIOs and IT leaders.</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2019/11/5-must-read-harvard-business-review-articles-december">Read Article</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2019/11/digital-transformation-3-people-pain-points">Digital transformation: 3 people pain points </a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/alan-duric" title="View user profile." class="username">Alan Duric</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">November 29, 2019</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>Digital transformation challenges always boil down to people. Are you soothing skepticism, opening up communication, and setting realistic goals?</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2019/11/digital-transformation-3-people-pain-points">Read Article</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-block-31 widget-block block"   class="panel-pane pane-block pane-block-31 widget-block block">
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title block-title">
  Email Capture</h2>


<div class="pane-content">
  <div style="padding-top:8px;">Keep up with the latest thoughts, strategies, and insights from CIOs &amp; IT leaders.</div>
<p><iframe id="dyfo" scrolling="no" src="https://enterprisersproject.com/eloqua-embedded-subscribe.html?offer_id=70160000000eIYXAA2" height="50" frameborder="0"></iframe></p>
</div>


</div>
        </div>
      </div>
    </div>
  </div>

</div><!-- /.selby-flipped -->

  </div>            </div>
          
          <!-- Feed icons (RSS, Atom icons etc -->
          
          
        </section><!-- /end #main-content -->

        <!-- region: Content Aside -->
        
      </div><!-- /end .content-inner -->
    </div><!-- /end #content-column -->

    <!-- regions: Sidebar first and Sidebar second -->
        
  </div><!-- /end #columns -->

  <!-- region: Tertiary Content -->
  
  <!-- region: Footer -->

</div>

<footer id="footer" class="clearfix" role="contentinfo">
  <div class="region region-footer"><div class="region-inner clearfix"><section id="block-bean-about-this-site" class="block block-bean odd first block-count-9 block-region-footer block-about-this-site" ><div class="block-inner clearfix">  
      <h2 class="block-title">About This Site</h2>
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p>The Enterprisers Project is an online publication and community focused on connecting CIOs and senior IT leaders with the "who, what, and how" of IT-driven business innovation.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. <a href="http://enterprisersproject.com" title="The Enterprisers Project">The Enterprisers Project</a> aspires to publish all content under a <a href="http://creativecommons.org/licenses/" title="Creative Commons license">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
<div>A note on advertising: The Enterprisers Project does not sell advertising on the site or in any of its newsletters.</div>
</div></div></div>  </div>
</div>
</div>
  </div></section><section id="block-bean-connect" class="block block-bean even block-count-10 block-region-footer block-connect" ><div class="block-inner clearfix">  
      <h2 class="block-title">Connect</h2>
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p class="footer-twitter"><a href="https://twitter.com/4enterprisers" target="_blank">Follow us @4Enterprisers on Twitter</a></p>
<p class="footer-facebook"><a href="https://www.facebook.com/enterprisersproject" target="_blank">Like The Enterprisers Project on Facebook</a></p>
<p class="footer-youtube"><a href="http://www.youtube.com/user/enterprisersproject" target="_blank">Watch us at The Enterprisers Project</a></p>
<p class="footer-linkedin"><a href="https://www.linkedin.com/company/the-enterprisers-project">Connect with us on Linkedin</a></p>
<p class="footer-rss"><a href="http://www.enterprisersproject.com/rss">RSS Feed</a></p>
</div></div></div>  </div>
</div>
</div>
  </div></section><section id="block-block-11" class="block block-block odd block-count-11 block-region-footer block-11" ><div class="block-inner clearfix">  
      <h2 class="block-title">Subscribe to our newsletter</h2>
  
  <div class="block-content content"><p>Subscribe to get the latest thoughts, strategies, and insights from enterprising peers.</p>
<iframe id="dyfo" height="50" src="https://enterprisersproject.com/eloqua-embedded-subscribe.html?offer_id=70160000000eIYXAA2" frameborder="0" scrolling="no"></iframe></div>
  </div></section><div id="block-block-4" class="block block-block no-title even block-count-12 block-region-footer block-4" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-8326"><a href="https://www.facebook.com/enterprisersproject" class="oep-facebook-menu" title="facebook">facebook</a></li>
<li class="leaf menu-depth-1 menu-item-1381"><a href="https://twitter.com/4enterprisers" class="oep-twitter-menu" title="twitter">Twitter</a></li>
<li class="leaf menu-depth-1 menu-item-1380"><a href="https://enterprisersproject.com/rss" class="oep-rss-menu" title="rss">RSS</a></li>
<li class="leaf menu-depth-1 menu-item-649"><a href="https://enterprisersproject.com/user/login">Log in</a></li>
<li class="last leaf menu-depth-1 menu-item-1301"><a href="https://enterprisersproject.com/user/register" title="">Register</a></li>
</ul></div>
  </div></div><div id="block-bean-copyright" class="block block-bean no-title odd block-count-13 block-region-footer block-copyright" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p>Copyright ©2019 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>
</div>
  </div></div><div id="block-bean-legal" class="block block-bean no-title even block-count-14 block-region-footer block-legal" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/privacy">Privacy Statement</a> | <a href="https://enterprisersproject.com/terms-and-conditions">Terms of use</a> | <a href="https://enterprisersproject.com/contact">Contact</a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div><div id="block-block-6" class="block block-block no-title odd last block-count-15 block-region-footer block-6" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><!-- Google Code for Remarketing tag --><!-- Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. For instructions on adding this tag and more information on the above requirements, read the setup guide: google.com/ads/remarketingsetup --><script type="text/javascript">
<!--//--><![CDATA[// ><!--

/* <![CDATA[ */
var google_conversion_id = 990030321;
var google_conversion_label = "rxV4CN_35QQQ8dOK2AM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]]]><![CDATA[> */

//--><!]]>
</script><script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
<!--//--><![CDATA[// ><!--


//--><!]]>
</script><p></p><noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" /></div>
<p></p></noscript>
</div>
  </div></div></div></div></footer>

<div class="region region-tep-social"><div class="region-inner clearfix"><div id="block-tep-social-tep-social-share" class="block block-tep-social no-title odd first last block-count-16 block-region-tep-social block-tep-social-share" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://enterprisersproject.com/article/2019/11/kubernetes-reality-check-3-takeaways-kubecon">
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_whatsapp"></a>
  <a class="a2a_button_email"></a>
  <!--<a href="/entityprint/node/12486"><img src="/sites/all/themes/oep/images/icon-print-pdf.svg"></a>-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_whatsapp"></a>
  <a class="a2a_button_email"></a>
  <!--<a href="/entityprint/node/12486"><img src="/sites/all/themes/oep/images/icon-print-pdf.svg"></a>-->
  </div></div>
  </div></div></div></div>  <script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}
//--><!]]>
</script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "Kubernetes reality check: 3 takeaways from KubeCon https://red.ht/2XF1ROn via @4enterprisers by @ghaff"
};
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779629","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":532,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
