<!DOCTYPE html>
<!--[if IEMobile 7]><html class="iem7" lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="lt-ie9 lt-ie8 lt-ie7" lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="lt-ie9 lt-ie8" lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="lt-ie9" lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html lang="en" dir="ltr"><!--<![endif]-->
<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<link rel="shortcut icon" href="https://enterprisersproject.com/sites/all/themes/oep/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="description" content="What are the common mistakes people make when starting out with CI/CD to speed software development? IT leaders and experts share advice." />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://enterprisersproject.com/article/2018/11/getting-started-cicd-6-pitfalls-avoid" />
<link rel="shortlink" href="https://enterprisersproject.com/node/9586" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://enterprisersproject.com/article/2018/11/getting-started-cicd-6-pitfalls-avoid" />
<meta property="og:title" content="Getting started with CI/CD: 6 pitfalls to avoid" />
<meta property="og:description" content="What are the common mistakes people make when starting out with CI/CD to speed software development? IT leaders and experts share advice." />
<meta property="og:image" content="https://enterprisersproject.com/sites/default/files/images/cio_bad_habits.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Getting started with CI/CD: 6 pitfalls to avoid" />
<meta name="twitter:description" content="What are the common mistakes people make when starting out with CI/CD to speed software development? IT leaders and experts share advice." />
<meta name="twitter:image" content="https://enterprisersproject.com/sites/default/files/images/cio_bad_habits.png" />
<title>Getting started with CI/CD: 6 pitfalls to avoid | The Enterprisers Project</title>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_TiQwzZAAjb88mdTw37tBPmWzzJkDuQ91Z1d8R4B2Mt8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_ED1WelyPEctSssOtKfqCRYsbJGoMnuo95qvzH4aJvdY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_2TvTObPRw9Kv8pYTjPMqJB94GYYRjUBo-ZFLgpr5Nd0.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_f8gWuoEJiafTr7WjJVGR2AOBaK0RPR53_yciBUapKME.css" media="only screen" />
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />

<!--[if lt IE 9]>
<link type="text/css" rel="stylesheet" href="https://enterprisersproject.com/sites/default/files/css/css_QqmufzDHao3hMGSzkKy2pUNnwQSoS_EUGRmyJCMT2ZY.css" media="screen" />
<![endif]-->
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_v7z_ueNi9EIrZXPI8So7AkuzyXuKekr2jbdDptsM5Oc.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_N3QrMaH3FSTG7AHsx81_k6rR6fScgg3ExVyzV8y3fcQ.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_DtBSLCkIkOZ3yvYCAEVYhd-lxagupjgu4EK2V6JpQvQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-44371138-1", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_Dq9icPpMam2QaSDmZOjgu71Tn5cD2k7EmQ95xntLB7U.js"></script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_Z1rMAOA2jn0APuP1PvZL7B4K9TRuzGwVIfSit8PNrRs.js"></script>
<script type="text/javascript">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</script>
<!--[if lt IE 9]>
<script src="https://enterprisersproject.com/sites/all/themes/adaptivetheme/at_core/scripts/html5.js?pizhk2"></script>
<![endif]-->
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-9586 node-type-article region-content site-name-hidden atr-7.x-3.x atv-7.x-3.1">
	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5P2XC4"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-5P2XC4');</script>
	<!-- End Google Tag Manager -->
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    
<div class="region region-top-bar"><div class="region-inner clearfix"><div id="block-block-3" class="block block-block no-title odd first block-count-1 block-region-top-bar block-3" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div id="mobnav-btn"><i class="icon-reorder"></i></div>
</div>
  </div></div><nav id="block-system-user-menu" class="block block-system block-menu no-title even block-count-2 block-region-top-bar block-user-menu"  role="navigation"><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-8326"><a href="https://www.facebook.com/enterprisersproject" class="oep-facebook-menu" title="facebook">facebook</a></li><li class="leaf menu-depth-1 menu-item-1381"><a href="https://twitter.com/4enterprisers" class="oep-twitter-menu" title="twitter">Twitter</a></li><li class="leaf menu-depth-1 menu-item-1380"><a href="/rss" class="oep-rss-menu" title="rss">RSS</a></li><li class="leaf menu-depth-1 menu-item-649"><a href="/user/login">Log in</a></li><li class="last leaf menu-depth-1 menu-item-1301"><a href="/user/register" title="">Register</a></li></ul></div>
  </div></nav><div id="block-bean-sponsored-by-responsive" class="block block-bean no-title odd last block-count-3 block-region-top-bar block-sponsored-by-responsive" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://www.redhat.com/en?sc_cid=701600000011jKuAAI" target="_blank"><img src="https://enterprisersproject.com/sites/all/themes/oep/images/rh-sponsored-horizontal.svg" alt="Sponsored by RedHat" class="sponsored-by-responsive--image" /></a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div></div></div><div class="region region-mobile-nav"><div class="region-inner clearfix"><div id="block-block-5" class="block block-block no-title odd first last block-count-4 block-region-mobile-nav block-5" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-4 sf-parent-items-4 sf-single-items-0 primary-menu clearfix"><li id="menu-1116-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-4 sf-parent-children-1 sf-single-children-3 menuparent"><a href="https://enterprisersproject.com/" class="sf-depth-1 menuparent">Articles</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-8346-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/digital-transformation" class="sf-depth-2">Digital Transformation</a></li>
<li id="menu-8331-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="https://enterprisersproject.com/tags/enterprise-technology" class="sf-depth-2 menuparent">Enterprise Technology</a>
<ul><li id="menu-9086-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="https://enterprisersproject.com/tags/hybrid-cloud" class="sf-depth-3">Hybrid cloud</a></li>
</ul></li>
<li id="menu-8351-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/it-strategy" class="sf-depth-2">IT Strategy</a></li>
<li id="menu-8341-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/tags/it-talent" class="sf-depth-2">IT Talent</a></li>
</ul></li>
<li id="menu-1181-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="https://enterprisersproject.com/cio-research" class="sf-depth-1 menuparent">CIO Research</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-8371-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/hbr-articles" class="sf-depth-2">HBR Articles</a></li>
<li id="menu-8356-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/researchreports" class="sf-depth-2">Research/Reports</a></li>
<li id="menu-8361-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/resources" class="sf-depth-2">Resources</a></li>
<li id="menu-8366-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/cio-research/roundtables" class="sf-depth-2">Roundtables</a></li>
<li id="menu-5046-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/what-is-digital-transformation" class="sf-depth-2 sf-depth-2">What is Digital Transformation?</a></li>
<li id="menu-10231-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/it-automation" class="sf-depth-2 sf-depth-2">Automation: The IT leader's guide</a></li>
<li id="menu-9731-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/devops" class="sf-depth-2 sf-depth-2">DevOps: The IT Leader's Guide</a></li>
<li id="menu-9576-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/hybrid-cloud" class="sf-depth-2 sf-depth-2">Hybrid cloud: The IT leader's guide</a></li>
<li id="menu-11696-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/ultimate-devops-hiring-guide" class="sf-depth-2 sf-depth-2">The ultimate DevOps hiring guide</a></li>
</ul></li>
<li id="menu-1115-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="https://enterprisersproject.com/what-enterpriser" class="sf-depth-1 menuparent sf-depth-1 menuparent">What is an Enterpriser?</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-1119-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/meet-enterprisers" class="sf-depth-2 sf-depth-2">Meet the Enterprisers</a></li>
<li id="menu-1118-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/are-you-enterpriser" class="sf-depth-2 sf-depth-2">Are you an enterpriser?</a></li>
</ul></li>
<li id="menu-1117-1" class="last even sf-item-4 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="https://enterprisersproject.com/about-this-project" class="sf-depth-1 menuparent sf-depth-1 menuparent">About This Project</a><br /><div class="mobnav-subarrow"></div>
<ul><li id="menu-5031-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/how-contribute" class="sf-depth-2 sf-depth-2">How to Contribute</a></li>
<li id="menu-5016-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="https://enterprisersproject.com/faq-contributors" class="sf-depth-2 sf-depth-2">FAQs for Contributors</a></li>
</ul></li>
</ul></div>
  </div></div></div></div><div id="page" class="container page">

  <!-- region: Leaderboard -->
  
  <header id="header" class="clearfix" role="banner">

          <!-- start: Branding -->
      <div id="branding" class="branding-elements clearfix">

                  <div id="logo">
            <a href="/"><img class="site-logo" src="https://enterprisersproject.com/sites/all/themes/oep/logo.png" alt="The Enterprisers Project" /></a>          </div>
        
                  <!-- start: Site name and Slogan hgroup -->
          <hgroup class="h-group" id="name-and-slogan">

                          <h1 class="element-invisible" id="site-name"><a href="/" title="Home page">The Enterprisers Project</a></h1>
            
                          <h2 id="site-slogan">A community of CIOs discussing the future of business and IT</h2>
            
          </hgroup><!-- /end #name-and-slogan -->
        
      </div><!-- /end #branding -->
    
    <!-- region: Header -->
    <div class="region region-header"><div class="region-inner clearfix"><div id="block-search-form" class="block block-search no-title odd first block-count-5 block-region-header block-form"  role="search"><div class="block-inner clearfix">  
  
  <div class="block-content content"><form action="/article/2018/11/getting-started-cicd-6-pitfalls-avoid" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="search" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-2l6HDIlQSe130k2l2gP6HQpc50nb7t0gpFUKPPcheAI" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form></div>
  </div></div><div id="block-bean-sponsored-by" class="block block-bean no-title even last block-count-6 block-region-header block-sponsored-by" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p style="float: right;"><a href="https://www.redhat.com/en?sc_cid=701600000011jKuAAI" target="_blank"><img alt="Supported by Red Hat" src="https://enterprisersproject.com/sites/default/files/images/red_hat_supported_by_red.jpg" title="Supported by Red Hat" width="125" height="56" /></a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div></div></div>
  </header>

  <!-- Navigation elements -->
  <div id="menu-bar" class="nav clearfix"><nav id="block-superfish-1" class="block block-superfish no-title menu-wrapper menu-bar-wrapper clearfix odd first last block-count-7 block-region-menu-bar block-1" >  
  
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-4 sf-parent-items-4 sf-single-items-0 primary-menu clearfix"><li id="menu-1116-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-4 sf-parent-children-1 sf-single-children-3 menuparent"><a href="/" class="sf-depth-1 menuparent">Articles</a> <div class="mobnav-subarrow"></div><ul><li id="menu-8346-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/digital-transformation" class="sf-depth-2">Digital Transformation</a></li><li id="menu-8331-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/enterprise-technology" class="sf-depth-2 menuparent">Enterprise Technology</a><ul><li id="menu-9086-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/hybrid-cloud" class="sf-depth-3">Hybrid cloud</a></li></ul></li><li id="menu-8351-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/it-strategy" class="sf-depth-2">IT Strategy</a></li><li id="menu-8341-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/it-talent" class="sf-depth-2">IT Talent</a></li></ul></li><li id="menu-1181-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/cio-research" class="sf-depth-1 menuparent">CIO Research</a> <div class="mobnav-subarrow"></div><ul><li id="menu-8371-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/cio-research/hbr-articles" class="sf-depth-2">HBR Articles</a></li><li id="menu-8356-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/cio-research/researchreports" class="sf-depth-2">Research/Reports</a></li><li id="menu-8361-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/cio-research/resources" class="sf-depth-2">Resources</a></li><li id="menu-8366-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/cio-research/roundtables" class="sf-depth-2">Roundtables</a></li><li id="menu-5046-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/what-is-digital-transformation" class="sf-depth-2">What is Digital Transformation?</a></li><li id="menu-10231-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/it-automation" class="sf-depth-2">Automation: The IT leader&#039;s guide</a></li><li id="menu-9731-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/devops" class="sf-depth-2">DevOps: The IT Leader&#039;s Guide</a></li><li id="menu-9576-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/hybrid-cloud" class="sf-depth-2">Hybrid cloud: The IT leader&#039;s guide</a></li><li id="menu-11696-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="/ultimate-devops-hiring-guide" class="sf-depth-2">The ultimate DevOps hiring guide</a></li></ul></li><li id="menu-1115-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/what-enterpriser" class="sf-depth-1 menuparent">What is an Enterpriser?</a> <div class="mobnav-subarrow"></div><ul><li id="menu-1119-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/meet-enterprisers" class="sf-depth-2">Meet the Enterprisers</a></li><li id="menu-1118-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/are-you-enterpriser" class="sf-depth-2">Are you an enterpriser?</a></li></ul></li><li id="menu-1117-1" class="last even sf-item-4 sf-depth-1 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/about-this-project" class="sf-depth-1 menuparent">About This Project</a> <div class="mobnav-subarrow"></div><ul><li id="menu-5031-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/how-contribute" class="sf-depth-2">How to Contribute</a></li><li id="menu-5016-1" class="last even sf-item-2 sf-depth-2 sf-no-children"><a href="/faq-contributors" class="sf-depth-2">FAQs for Contributors</a></li></ul></li></ul>
  </nav></div>    
  <!-- Breadcrumbs -->
  
  <!-- Messages and Help -->
    
  <!-- region: Secondary Content -->
  
  <div id="columns" class="columns clearfix">
    <div id="content-column" class="content-column" role="main">
      <div class="content-inner">

        <!-- region: Highlighted -->
        
        <section id="main-content">

          
                      <header id="main-content-header" class="clearfix">

                              <h1 id="page-title">
                  Getting started with CI/CD: 6 pitfalls to avoid                </h1>
              
              
            </header>
          
          <!-- region: Main Content -->
                      <div id="content" class="region">
              <div id="block-system-main" class="block block-system no-title odd first last block-count-8 block-region-content block-main" >  
  
  
<div class="panel-display selby-flipped clearfix radix-selby-flipped" >

  <div class="container-fluid">
    <div class="row">
      <div class="col-md-8 panel-panel">
        <div class="row">
          <div class="col-md-12 radix-layouts-contentheader panel-panel">
            <div class="panel-pane pane-node-title no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <h1>Getting started with CI/CD: 6 pitfalls to avoid</h1>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-article-subhead no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden view-mode-_custom_display">
    <div class="field-items">
                  <h2>What are the common mistakes people make when starting out with CI/CD to speed software development? IT leaders and experts share advice</h2>
            </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-rate-widget no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-1bd7d71ebea7aa23c3967a7045920f10 rate-node-9586-1-1" id="rate-node-9586-1-1"><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/2018/11/getting-started-cicd-6-pitfalls-avoid?rate=Vr3InHGGu-kSwrRPZkxHxbdbUvoA4reLf2LlzNJem2U" title="up">up</a><div class="rate-info">9 readers like this</div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-node-author block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">By </h2>
        
    
    <div class="block-content">
      <a href="/user/kevin-casey" title="View user profile." class="username">Kevin Casey</a>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><section class="panel-pane pane-node-created block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title"> on </h2>
        
    
    <div class="block-content">
      November 28, 2018    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-basic-image-image no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-field-basic-image-image field-type-image field-label-hidden view-mode-_custom_display"><div class="field-items"><figure class="clearfix field-item even"><img class="620x350 image-style-620x350" src="https://enterprisersproject.com/sites/default/files/styles/620x350/public/images/cio_bad_habits.png?itok=7Q71nDot" width="620" height="350" alt="Bad habits in IT" /></figure></div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-body no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="field field-name-body field-type-text-with-summary field-label-hidden view-mode-_custom_display"><div class="field-items"><div class="field-item even"><p>What shapes the long-term success of your <a href="https://opensource.com/article/18/8/what-cicd?extIdCarryOver=true&amp;sc_cid=7016000000127eyAAA">CI/CD</a> effort? A faster, more automated pipeline for software development? We recently outlined<a href="https://enterprisersproject.com/article/2018/11/getting-started-cicd-4-success-factors"> 4 success factors when getting started with CI/CD</a> – and all led back to culture.</p>
<p>That’s helpful, but it’s also productive to look at the downsides – not of CI/CD itself, but of common mistakes organizations make, especially when they’re just starting out.</p>
<p><strong>[ Need a primer on continuous integration/continuous delivery? Read <a href="https://www.redhat.com/en/topics/devops/what-is-ci-cd?intcmp=701f2000000tjyaAAA" target="_blank">What is CI/CD?</a> ]</strong></p>
<p>“If done right, proper continuous delivery and integration can lead to great customer experiences,” says Joy Scharmen, director of DevOps at <a href="https://www.optimizely.com/">Optimizely</a>.</p>
<p>In the interest of doing CI/CD right, we asked Scharmen and other IT leaders to share some of the common ways teams go wrong. Here’s what they had to say.</p>
<h2>1. Don't follow the recipe for tool salad</h2>
<p>I could walk into a Home Depot today and buy a bunch of expensive tools and materials; I’d walk out still not knowing how to build a new back deck on my house. Thankfully, I have just enough common sense to not spend money loading up my garage with a bunch of stuff that I don’t really understand.</p>
<p>IT teams need to apply the same common sense when determining the right tools and technologies for their CI/CD pipelines, or they risk ending up with what Nate Berent-Spillson, senior director of delivery at <a href="https://www.nexient.com/">Nexient</a>, calls “tool salad.” (Mmm, sounds delicious.)</p>
<p>“I’ve seen companies go on a buying spree, picking up this tool, that platform, and that system over there, yet in the end, they weren’t equipped to build an iOS app,” Berent-Spillson says. “The unspoken idea was that if they bought enough tools, the capabilities they wanted would have to be in there somewhere.”</p>
<p>Choosing the right platforms and tools is indeed an important part of your CI/CD plan, but your needs should dictate the tools, not vice versa.</p>
<p>“Instead of thinking about what tools you need, think first about the capabilities you want, like ‘build pipeline for iOS,’ ‘build pipeline for Android,’ ‘mobile app distribution for both platforms,’ or 'signing certificate security and management,’” Berent-Spillson advises. “That way, you’re focusing on how to move value through the system. The choice of tools will follow from that.”</p>
<h2>2. Don't mess up on metrics and feedback</h2>
<p>Continuous measurement is an important success factor for CI/CD, but it comes with a downside: Picking the wrong things to measure.</p>
<p></p><div class="embedded-callout-text callout-float-right">“One of the biggest pitfalls to watch out for is picking the wrong metrics to test."</div>
<p>“One of the biggest pitfalls to watch out for is picking the wrong metrics to test,” Scharmen at Optimizely says. “Businesses can easily guide their products down the wrong direction if they choose the wrong metrics to track and measure.”</p>
<p>Because CI/CD and <a href="https://enterprisersproject.com/tags/devops">DevOps</a> often go hand-in-hand, there can be some overlap in the metrics you use to evaluate their impacts. The key principle here: Track what actually matters to your organization. As Gordon Haff, technology evangelist, Red Hat, <a href="https://enterprisersproject.com/article/2017/7/devops-metrics-are-you-measuring-what-matters">wrote previously about DevOps metrics</a>: “A metric is properly thought of as a key performance indicator for data – a measurement that’s important to you in some fundamental way.”</p>
<p><strong>[ Read the full article: <a href="https://enterprisersproject.com/article/2017/7/devops-metrics-are-you-measuring-what-matters">DevOps metrics: Are you measuring what matters?</a> ]</strong></p>
<p>The same idea applies to your CI/CD pipeline: Make sure you know what’s important, not just to you but to the organization.</p>
<p>“Different members of an IT organization or team have different priorities, so it’s important to assess which data everyone wants and needs from the start,” Scharmen says.</p>
<p>Scharmen notes another related pitfall: Getting duped by data via misinterpreting it, confirmation bias, or other reasons. This applies not only to your ongoing measurement but to testing itself in your pipeline.</p>
<p>“Misinterpreting a test can be worse than not running one at all and can quickly negate the value of an experimentation by injecting uncertainty and fear into a process that’s meant to provide clarity and confidence,” Scharmen says.</p>
<p>Finally, don’t forget about your actual production application or service. CI/CD doesn’t actually come with a defect-free guarantee as code moves into production. You still need a feedback loop there.</p>
<p>“Avoid the pitfall of having automated the delivery of software from source code to end user but not automating the collection of live, passive feedback, either from end users or automated tests,” says Maxwell Bloch, consultant at <a href="https://www.appliedis.com/">Applied Information Sciences (AIS)</a>. “For example, instrument your application to provide telemetry and error occurrences. Many bugs will be detected earlier in the CI/CD process, but some bugs will only occur with real usage.”</p>
<h2>3. Don't give people a way to bypass the CI/CD pipeline</h2>
<p>Don’t enable team members to bypass the pipeline other than under the most extraordinary of circumstances. This can be particularly important if you’re dealing with skepticism or cultural stasis in the earlier stages of your shift to CI/CD.</p>
<p>“If your CI/CD platform is not the only way, excluding an emergency break-glass method, to deploy code to your production environment, it will become tempting for teams to work around it when your testing [finds] code issues that are not easily solvable,” says Jerry Gamblin, principal security engineer at <a href="https://www.kennasecurity.com/">Kenna Security</a>.</p>
<p>A promise of CI/CD is that it will enable application teams to move faster than before, but there may still be real reasons to slow down, and that can cause some frustration or feelings of failure. (This is another reason why cultural health is as important as technical decisions and architecture: A healthy culture can handle the speed bumps.)</p>
<p>You might automate your pipeline iteratively or in small chunks, and that’s fine. Similarly, you might build a CI/CD pipeline for a specific application team – also fine. But no matter your approach, don’t effectively give people the chance to opt out of your CI/CD pipeline if they decide it doesn’t suit them for some reason.</p>
<h2 class="element-invisible">Pages</h2><div class="item-list item-list-pager"><ul class="pager"><li class="pager-current even first">1</li><li class="pager-item odd"><a title="Go to page 2" href="/article/2018/11/getting-started-cicd-6-pitfalls-avoid?page=1">2</a></li><li class="pager-next even"><a title="Go to next page" href="/article/2018/11/getting-started-cicd-6-pitfalls-avoid?page=1">next ›</a></li><li class="pager-last odd last"><a title="Go to last page" href="/article/2018/11/getting-started-cicd-6-pitfalls-avoid?page=1">last »</a></li></ul></div></div></div></div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-views-panes pane-related-articles-panel-pane-1 block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Related content</h2>
        
    
    <div class="block-content">
      <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 view-dom-id-f7cfbc5a1eaa1b3c2d817a4d2aadac9c">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/how-do-cios-deal-agile-and-devops"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/Aaron%20Stibel%20CIO.jpg?itok=lfjzbGv7" width="222" height="125" alt="Aaron Stibel CIO" title="Aaron Stibel CIO" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/how-do-cios-deal-agile-and-devops">How do CIOs deal with agile and DevOps?</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/2014/7/devops-not-synonym-application-development"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/CIO_Cultural_Crossroads.png?itok=jJRY9kkL" width="222" height="125" alt="CIOs are at a cultural crossroads" title="CIOs are at a cultural crossroads" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2014/7/devops-not-synonym-application-development">DevOps is not a synonym for application development</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd views-row-last">
      
  <div class="views-field views-field-field-basic-image-image">        <div class="field-content"><a href="/article/2014/10/gene-kim-what-high-performing-it-organizations-do-differently"><img class="222x125 image-style-222x125" src="https://enterprisersproject.com/sites/default/files/styles/222x125/public/images/CIO%20Big%20Data.png?itok=WG8K98lG" width="222" height="125" alt="CIO Big Data" title="CIO Big Data" /></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2014/10/gene-kim-what-high-performing-it-organizations-do-differently">Gene Kim: What high-performing IT organizations do differently</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-entity-field pane-node-field-article-tags no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <section class="field field-name-field-article-tags field-type-taxonomy-term-reference field-label-inline clearfix view-mode-_custom_display"><h2 class="field-label">Tags:&nbsp;</h2><ul class="field-items"><li class="field-item even"><a href="/tags/it-strategy">IT Strategy</a></li><li class="field-item odd"><a href="/tags/application-development">Application Development</a></li><li class="field-item even"><a href="/tags/devops">DevOps</a></li><li class="field-item odd"><a href="/tags/agile-0">Agile</a></li></ul></section>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-post-comment pane-bean-post-comment-block-on-articles no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="button"><a href="#comment">Post Comment</a></div><span class='com_count'>Comments 0</span> | <span class='com_link'><a href='#comment'>Add yours Below</a></span>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-node-comment-form block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Comment Now</h2>
        
    
    <div class="block-content">
      <a name="comment"></a><form class="comment-form user-info-from-cookie" action="/article/2018/11/getting-started-cicd-6-pitfalls-avoid#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<div class="form-item form-type-textfield form-item-homepage">
  <label for="edit-homepage">Homepage </label>
 <input type="text" id="edit-homepage" name="homepage" value="" size="30" maxlength="255" class="form-text" />
</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input type="hidden" name="form_build_id" value="form-1n-HuGcFzX8X_Gco84RXgw305lUtrgZQW8VUPvF0Mc4" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-notify">
 <input type="checkbox" id="edit-notify" name="notify" value="1" class="form-checkbox" />  <label class="option" for="edit-notify">Notify me when new comments are posted </label>

</div>
<div id="edit-notify-type" class="form-radios"><div class="form-item form-type-radio form-item-notify-type">
 <input type="radio" id="edit-notify-type-1" name="notify_type" value="1" checked="checked" class="form-radio" />  <label class="option" for="edit-notify-type-1">All comments </label>

</div>
<div class="form-item form-type-radio form-item-notify-type">
 <input type="radio" id="edit-notify-type-2" name="notify_type" value="2" class="form-radio" />  <label class="option" for="edit-notify-type-2">Replies to my comment </label>

</div>
</div><input type="hidden" name="honeypot_time" value="1543544400|UX00mS_eXxIslVTHi_JH6mPG4m4Ba4k9Ucf-rsPAVVY" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/terms-and-conditions">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="30104041" />
<input type="hidden" name="captcha_token" value="d22d145278efbc354e2a038d69f8d3c7" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdzKzYUAAAAAMFHjKIs8QmN8y2QGTgbO6ze0Rgn" data-theme="light" data-type="image"></div></div></fieldset>
<div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Submit Comment" class="form-submit" /></div></div></form>    </div>

    
    
  </div>
</section>
          </div>
        </div>
        <div class="row">
          <div class="col-md-6 radix-layouts-contentcolumn1 panel-panel">
                      </div>
          <div class="col-md-6 radix-layouts-contentcolumn2 panel-panel">
                      </div>
        </div>
        <div class="row">
          <div class="col-md-12 radix-layouts-contentfooter panel-panel">
                      </div>
        </div>
      </div>
      <div class="col-md-4 radix-layouts-sidebar panel-panel">
        <div class="panel-panel-inner">
          <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1 no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-4919099311f9db498ca5f95d4580caa7">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-user-picture">        <div class="field-content"><img class="150x150 image-style-150x150" src="https://enterprisersproject.com/sites/default/files/styles/150x150/public/bio_kevin_casey.png?itok=SOmJjOrz" width="150" height="150" alt="" /></div>  </div>  
  <div class="views-field views-field-field-user-about">        <span class="field-content">Kevin Casey writes about technology and business for a variety of publications. He won an Azbee Award, given by the American Society of Business Publication Editors, for his InformationWeek.com story, "Are You Too Old For IT?" He's a former community choice honoree in the Small Business Influencer Awards.</span>  </div>  
  <div class="views-field views-field-nothing">        <span class="field-content"><a href="/user/kevin-casey">» More about me</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-block-36 no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <p><a href="https://enterprisersproject.com/cio-new-rules-infographic?sc_cid=701f2000000rcquaak"><img alt="7 New CIO Rules of Road " src="https://enterprisersproject.com/sites/default/files/styles/panopoly_image_original/public/images/new_rules_infographic_widget3.png" title="7 New CIO Rules of Road " width="300" height="200" /></a></p>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-bean-widget-hbr-report-it-talent-cris no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/IT-Talent-Report" target="_blank"><img alt="Harvard Business Review: IT Talent Crisis: Proven Advice from CIOs and HR Leaders" class="media-image img__fid__379346 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__Harvard Business Review: IT Talent Crisis: Proven Advice from CIOs and HR Leaders attr__field_file_image_title_text[und][0][value]__Harvard attr__field_folder[und]__196" height="200" src="https://enterprisersproject.com/sites/default/files/widget_it_talent_crisis_hbr_report.png" title="Harvard Business Review: IT Talent Crisis: Proven Advice from CIOs and HR Leaders" width="300" /></a></p>
</div></div></div>  </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-bean-cios-we-welcome-you-to-join-the no-title block">
  <div class="block-inner clearfix">
    
            
    
    <div class="block-content">
      <div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/how-contribute" target="_blank"><img alt="CIOs: We welcome you to join the conversation" class="media-image img__fid__379366 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__CIOs: We welcome you to join the conversation attr__field_file_image_title_text[und][0][value]__CIOs: attr__field_folder[und]__196" height="200" src="https://enterprisersproject.com/sites/default/files/widget_cios_we_welcome_you_join_conversation.png" title="CIOs: We welcome you to join the conversation" width="300" /></a></p>
</div></div></div>  </div>
</div>
    </div>

    
    
  </div>
</div>
<div class="panel-separator"></div><section class="panel-pane pane-views pane-article-view block">
  <div class="block-inner clearfix">
    
              <h2 class="pane-title block-title">Related Topics</h2>
        
    
    <div class="block-content">
      <div class="view view-article-view view-id-article_view view-display-id-block_3 view-dom-id-4381d786c6c4f5ae97566485fbd92a75">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/11/3-aging-it-specialties-just-won-t-retire">3 aging IT specialties that just won&#039;t retire</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/stephanie-overby" title="View user profile." class="username">Stephanie Overby</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">November 29, 2018</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>That system runs what? IT leaders face a quandary as Boomers vanish, but the need for COBOL, mainframe, and legacy storage skills does not.</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2018/11/3-aging-it-specialties-just-won-t-retire">Read Article</a></span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/kubernetes-guide">Kubernetes essential guide: 10 must-reads</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/laurianne-mclaughlin" title="View user profile." class="username">Laurianne McLaughlin</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">November 28, 2018</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>Kubernetes, containers, and automation have become crucial to IT goals – and practically beg for continuous learning. Consider this a mini-class</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/kubernetes-guide">Read Article</a></span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/11/getting-started-cicd-4-success-factors">Getting started with CI/CD: 4 success factors</a></span>  </div>  
  <div class="views-field views-field-name">        <span class="field-content">Submitted By <a href="/user/kevin-casey" title="View user profile." class="username">Kevin Casey</a></span>  </div>  
  <div class="views-field views-field-created">        <span class="field-content">November 27, 2018</span>  </div>  
  <div class="views-field views-field-body">        <div class="field-content"><p>How can CI/CD speed up your software development pipeline? First of all, it’s more about culture and process than tools.</p>
</div>  </div>  
  <div class="views-field views-field-view-node">        <span class="field-content"><a href="/article/2018/11/getting-started-cicd-4-success-factors">Read Article</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div>    </div>

    
    
  </div>
</section>
<div class="panel-separator"></div><div class="panel-pane pane-block pane-block-31 widget-block block"   class="panel-pane pane-block pane-block-31 widget-block block">
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title block-title">
  Email Capture</h2>


<div class="pane-content">
  <div style="padding-top:8px;">Keep up with the latest thoughts, strategies, and insights from CIOs &amp; IT leaders.</div>
<p><iframe id="dyfo" scrolling="no" src="https://enterprisersproject.com/eloqua-embedded-subscribe.html?offer_id=70160000000eIYXAA2" height="50" frameborder="0"></iframe></p>
</div>


</div>
        </div>
      </div>
    </div>
  </div>

</div><!-- /.selby-flipped -->

  </div>            </div>
          
          <!-- Feed icons (RSS, Atom icons etc -->
          
          
        </section><!-- /end #main-content -->

        <!-- region: Content Aside -->
        
      </div><!-- /end .content-inner -->
    </div><!-- /end #content-column -->

    <!-- regions: Sidebar first and Sidebar second -->
        
  </div><!-- /end #columns -->

  <!-- region: Tertiary Content -->
  
  <!-- region: Footer -->

</div>

<footer id="footer" class="clearfix" role="contentinfo">
  <div class="region region-footer"><div class="region-inner clearfix"><section id="block-bean-about-this-site" class="block block-bean odd first block-count-9 block-region-footer block-about-this-site" ><div class="block-inner clearfix">  
      <h2 class="block-title">About This Site</h2>
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p>The Enterprisers Project is an online publication and community focused on connecting CIOs and senior IT leaders with the "who, what, and how" of IT-driven business innovation.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. <a href="http://enterprisersproject.com" title="The Enterprisers Project">The Enterprisers Project</a> aspires to publish all content under a <a href="http://creativecommons.org/licenses/" title="Creative Commons license">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
<div>A note on advertising: The Enterprisers Project does not sell advertising on the site or in any of its newsletters.</div>
</div></div></div>  </div>
</div>
</div>
  </div></section><section id="block-bean-connect" class="block block-bean even block-count-10 block-region-footer block-connect" ><div class="block-inner clearfix">  
      <h2 class="block-title">Connect</h2>
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p class="footer-twitter"><a href="https://twitter.com/4enterprisers" target="_blank">Follow us @4Enterprisers on Twitter</a></p>
<p class="footer-facebook"><a href="https://www.facebook.com/enterprisersproject" target="_blank">Like The Enterprisers Project on Facebook</a></p>
<p class="footer-youtube"><a href="http://www.youtube.com/user/enterprisersproject" target="_blank">Watch us at The Enterprisers Project</a></p>
<p class="footer-linkedin"><a href="https://www.linkedin.com/company/the-enterprisers-project">Connect with us on Linkedin</a></p>
<p class="footer-rss"><a href="http://www.enterprisersproject.com/rss">RSS Feed</a></p>
</div></div></div>  </div>
</div>
</div>
  </div></section><section id="block-block-11" class="block block-block odd block-count-11 block-region-footer block-11" ><div class="block-inner clearfix">  
      <h2 class="block-title">Subscribe to our newsletter</h2>
  
  <div class="block-content content"><p>Subscribe to get the latest thoughts, strategies, and insights from enterprising peers.</p>
<iframe id="dyfo" height="50" src="https://enterprisersproject.com/eloqua-embedded-subscribe.html?offer_id=70160000000eIYXAA2" frameborder="0" scrolling="no"></iframe></div>
  </div></section><div id="block-block-4" class="block block-block no-title even block-count-12 block-region-footer block-4" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><ul class="menu clearfix"><li class="first leaf menu-depth-1 menu-item-8326"><a href="https://www.facebook.com/enterprisersproject" class="oep-facebook-menu" title="facebook">facebook</a></li>
<li class="leaf menu-depth-1 menu-item-1381"><a href="https://twitter.com/4enterprisers" class="oep-twitter-menu" title="twitter">Twitter</a></li>
<li class="leaf menu-depth-1 menu-item-1380"><a href="https://enterprisersproject.com/rss" class="oep-rss-menu" title="rss">RSS</a></li>
<li class="leaf menu-depth-1 menu-item-649"><a href="https://enterprisersproject.com/user/login">Log in</a></li>
<li class="last leaf menu-depth-1 menu-item-1301"><a href="https://enterprisersproject.com/user/register" title="">Register</a></li>
</ul></div>
  </div></div><div id="block-bean-copyright" class="block block-bean no-title odd block-count-13 block-region-footer block-copyright" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p>Copyright ©2018 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>
</div>
  </div></div><div id="block-bean-legal" class="block block-bean no-title even block-count-14 block-region-footer block-legal" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="entity entity-bean bean-redhat clearfix">

  <div class="content">
    <div class="field field-name-field-basic-text-text field-type-text-long field-label-hidden view-mode-default"><div class="field-items"><div class="field-item even"><p><a href="https://enterprisersproject.com/privacy">Privacy Statement</a> | <a href="https://enterprisersproject.com/terms-and-conditions">Terms of use</a> | <a href="https://enterprisersproject.com/contact">Contact</a></p>
</div></div></div>  </div>
</div>
</div>
  </div></div><div id="block-block-6" class="block block-block no-title odd last block-count-15 block-region-footer block-6" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><!-- Google Code for Remarketing tag --><!-- Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. For instructions on adding this tag and more information on the above requirements, read the setup guide: google.com/ads/remarketingsetup --><script type="text/javascript">
<!--//--><![CDATA[// ><!--

/* <![CDATA[ */
var google_conversion_id = 990030321;
var google_conversion_label = "rxV4CN_35QQQ8dOK2AM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]]]><![CDATA[> */

//--><!]]>
</script><script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
<!--//--><![CDATA[// ><!--


//--><!]]>
</script><p></p><noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" /></div>
<p></p></noscript>
</div>
  </div></div></div></div></footer>

<div class="region region-tep-social"><div class="region-inner clearfix"><div id="block-tep-social-tep-social-share" class="block block-tep-social no-title odd first last block-count-16 block-region-tep-social block-tep-social-share" ><div class="block-inner clearfix">  
  
  <div class="block-content content"><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://enterprisersproject.com/article/2018/11/getting-started-cicd-6-pitfalls-avoid">
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  </div></div>
  </div></div></div></div>  <script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}
//--><!]]>
</script>
<script type="text/javascript" src="https://enterprisersproject.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "Getting started with CI/CD: 6 pitfalls to avoid https://red.ht/2QoUedv via @4enterprisers by @kevinrcasey"
};
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779629","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":820,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
